View Issue Details

IDProjectCategoryView StatusLast Update
0001573OpenFOAM[All Projects] Bugpublic2015-03-15 22:10
Reporteruser1103Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0001573: Incorrect parameters for xargs -I
DescriptionTrying to run etc/wcleanAll displays an xargs error:

   Removing platforms/ subdirectores
   Removing *.dep files
   Cleaning Make subdirectories
   xargs: {}: No such file or directory

I notice that the '-I' parameter is incorrectly specified. It should be of the form xargs -I {} cmd {}. This is described here:

http://www.cyberciti.biz/faq/linux-unix-bsd-xargs-construct-argument-lists-utility/

Discovered the issue on MacOS X and verified issue also impacts Linux based environments. Used Raspbian, since this was available to me.
TagsNo tags attached.

Activities

henry

2015-03-15 22:10

manager   ~0004144

Resolved by commit 2bd5085835dad859154bebf901cfb477a90178fd

Issue History

Date Modified Username Field Change
2015-03-15 21:45 user1103 New Issue
2015-03-15 22:10 henry Note Added: 0004144
2015-03-15 22:10 henry Status new => resolved
2015-03-15 22:10 henry Resolution open => fixed
2015-03-15 22:10 henry Assigned To => henry
2015-03-24 00:17 liuhuafei Issue cloned: 0001606