View Issue Details

IDProjectCategoryView StatusLast Update
0001553OpenFOAM[All Projects] Bugpublic2015-03-05 20:23
Reporteruser4Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS Version13.2
Product Version 
Fixed in Version 
Summary0001553: adjustPhi uses strict tolerance
DescriptionIn adjustPhi it uses the totalFlux for normalisation and stabilises it to 1e-300. In the mixerVesselAMI2D case with a different scotch decomposition library I can end up with the FatalError message:

Total flux : 1e-300
Specified mass inflow : 0.0002638918998717107
Specified mass outflow : 0.0002638918998717106
Adjustable mass outflow : 0

which triggers the FatalError exit (1e-15 / 1e-300)

- I don't get this error with default scotch decomposition
- I can work around it by initialising some flow or writing the mesh in binary
TagsNo tags attached.

Activities

henry

2015-03-04 10:31

manager   ~0003952

Is the problem caused by the AMI being non-conservative?

user4

2015-03-04 12:23

  ~0003953

Don't know but this is at the first iteration & binary mesh writing fixes it. It looks more like a numerical truncation error (inflow and outflow differ only in the last digit)

Other: why is the check on processorFvsPatchScalarField and not phip.coupled()?

henry

2015-03-04 12:40

manager   ~0003954

Why is there

Specified mass inflow : 0.0002638918998717107
Specified mass outflow : 0.0002638918998717106

The mixerVesselAMI2D case is closed, there should be no inflow or outflow or have you added inlets and outlets?

user4

2015-03-04 13:37

  ~0003955

I have not changed the case.

It currently seems to integrate flux across cyclic/cyclicAMI as well:

            if (!isA<processorFvsPatchScalarField>(phip))

I think this should be

            if (!phip.coupled())

henry

2015-03-05 20:23

manager   ~0003972

Resolved by commit ade709a58e9c0dbe52bb8843aa58959e9de3d805

Issue History

Date Modified Username Field Change
2015-03-04 09:48 user4 New Issue
2015-03-04 10:31 henry Note Added: 0003952
2015-03-04 12:23 user4 Note Added: 0003953
2015-03-04 12:40 henry Note Added: 0003954
2015-03-04 13:37 user4 Note Added: 0003955
2015-03-05 20:23 henry Note Added: 0003972
2015-03-05 20:23 henry Status new => resolved
2015-03-05 20:23 henry Resolution open => fixed
2015-03-05 20:23 henry Assigned To => henry