View Issue Details

IDProjectCategoryView StatusLast Update
0001546OpenFOAM[All Projects] Bugpublic2015-02-24 16:50
Reporteruser1091Assigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001546: Installation Library errors (libfiniteVolume.so missing)
DescriptionUbuntu 14.04
Installation of OpenFOAM via normal methods, appeared to complete successfully. However, verification of the installation failed:

kevin@stig:~$ icoFoam -help
icoFoam: error while loading shared libraries: libfiniteVolume.so: cannot open shared object file: No such file or directory

 
Steps To ReproduceAll I did was to install OpenFOAM 2.3.1 via standard apt-get methods, on Ubuntu 14.04. When I tried to run the first verification, I got this error.
TagsNo tags attached.

Activities

wyldckat

2015-02-23 22:23

updater   ~0003873

A few quick questions:

 1- How many OpenFOAM versions do you have installed?

 2- Did you follow the steps from the section "User Configuration"? Namely from this page: http://www.openfoam.org/download/ubuntu.php

 3- What do you get when you run the following command?

      which icoFoam

user1091

2015-02-23 22:28

  ~0003874

1. I had previously installed 2.3.0 as root, as at the time, you did not support the 14.04 distro (and it failed to install via non-root). I would prefer to run as myself, and saw that you now supported 14.04 directly... so I attempted to install it.
I also have installed Caelus, which is based on an older version of OpenFOAM, I believe.
2. Those were the exact steps that I used to install (that was the page I used for instruction).
3. which icoFoam returns:
/opt/openfoam231/platforms/linux64GccDPOpt/bin/icoFoam

user1091

2015-02-23 22:32

  ~0003875

This is the output from the installation:

kevin@stig:~/Downloads$ sudo apt-get install openfoam231
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  kde-l10n-engb linux-image-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  binutils binutils-dev csh libptscotch-5.1 libptscotch-dev openmpi-bin
Suggested packages:
  binutils-doc libvtk5-dev paraview-dev libhdf5-dev gfortran openmpi-checkpoint
The following NEW packages will be installed:
  binutils-dev csh libptscotch-5.1 libptscotch-dev openfoam231 openmpi-bin
The following packages will be upgraded:
  binutils
1 upgraded, 6 newly installed, 0 to remove and 524 not upgraded.
Need to get 75.4 MB of archives.
After this operation, 468 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  openfoam231
Install these packages without verification? [y/N] y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main binutils amd64 2.24-5ubuntu3.1 [2,076 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ trusty/universe csh amd64 20110502-2ubuntu2 [243 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ trusty/universe libptscotch-5.1 amd64 5.1.12b.dfsg-2build1 [522 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main binutils-dev amd64 2.24-5ubuntu3.1 [1,967 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ trusty/universe openmpi-bin amd64 1.6.5-8 [84.5 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ trusty/universe libptscotch-dev amd64 5.1.12b.dfsg-2build1 [2,974 kB]
Get:7 http://www.openfoam.org/download/ubuntu/ trusty/main openfoam231 amd64 0-1 [67.6 MB]
Fetched 75.4 MB in 1min 20s (938 kB/s)
(Reading database ... 229858 files and directories currently installed.)
Preparing to unpack .../binutils_2.24-5ubuntu3.1_amd64.deb ...
Unpacking binutils (2.24-5ubuntu3.1) over (2.24-5ubuntu3) ...
Selecting previously unselected package csh.
Preparing to unpack .../csh_20110502-2ubuntu2_amd64.deb ...
Unpacking csh (20110502-2ubuntu2) ...
Selecting previously unselected package libptscotch-5.1.
Preparing to unpack .../libptscotch-5.1_5.1.12b.dfsg-2build1_amd64.deb ...
Unpacking libptscotch-5.1 (5.1.12b.dfsg-2build1) ...
Selecting previously unselected package binutils-dev.
Preparing to unpack .../binutils-dev_2.24-5ubuntu3.1_amd64.deb ...
Unpacking binutils-dev (2.24-5ubuntu3.1) ...
Selecting previously unselected package openmpi-bin.
Preparing to unpack .../openmpi-bin_1.6.5-8_amd64.deb ...
Unpacking openmpi-bin (1.6.5-8) ...
Selecting previously unselected package openfoam231.
Preparing to unpack .../openfoam231_0-1_amd64.deb ...
Unpacking openfoam231 (0-1) ...
Selecting previously unselected package libptscotch-dev.
Preparing to unpack .../libptscotch-dev_5.1.12b.dfsg-2build1_amd64.deb ...
Unpacking libptscotch-dev (5.1.12b.dfsg-2build1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for doc-base (0.10.5) ...
Processing 1 added doc-base file...
Setting up binutils (2.24-5ubuntu3.1) ...
Setting up csh (20110502-2ubuntu2) ...
update-alternatives: using /bin/bsd-csh to provide /bin/csh (csh) in auto mode
Setting up libptscotch-5.1 (5.1.12b.dfsg-2build1) ...
Setting up binutils-dev (2.24-5ubuntu3.1) ...
Setting up openmpi-bin (1.6.5-8) ...
update-alternatives: using /usr/bin/mpirun.openmpi to provide /usr/bin/mpirun (mpirun) in auto mode
Setting up openfoam231 (0-1) ...

** To use OpenFOAM please add
**
** . /opt/openfoam231/etc/bashrc
**
** To your ~/.bashrc

Setting up libptscotch-dev (5.1.12b.dfsg-2build1) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...

wyldckat

2015-02-23 23:29

updater   ~0003877

Disclaimer: I'm just a fellow bug reporter... who happens to also try and fix bugs.
It's the OpenFOAM Foundation that is providing support for the Deb packages of OpenFOAM for Ubuntu... and I'm not part of said Foundation ;)


As for the problem you're having, I would have to try and reproduce the same error, which I won't be able to do today. I'm not familiar enough with Caelus-CML to know how they implemented their shell environment.
Nonetheless, here are a few more commands that would help diagnose the problem:

  ls -l $FOAM_LIBBIN/libfiniteVolume.so

  ldd $(which icoFoam)

user1091

2015-02-24 00:11

  ~0003878

kevin@stig:~$ ls -l $FOAM_LIBBIN/libfiniteVolume.so
-rw-r--r-- 1 root root 24221359 Dec 7 09:54 /opt/openfoam231/platforms/linux64GccDPOpt/lib/libfiniteVolume.so

kevin@stig:~$ ldd $(which icoFoam)
    linux-vdso.so.1 => (0x00007fff38565000)
    libfiniteVolume.so => not found
    libsampling.so => /home/kevin/Caelus/Caelus-4.10/platforms/linux64SystemDP/lib/libsampling.so (0x00007f405f4e0000)
    libOpenFOAM.so => not found
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f405f2dc000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f405efd7000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f405ecd1000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f405eabb000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f405e6f4000)
    libPstream.so => not found
    libcore.so => /home/kevin/Caelus/Caelus-4.10/platforms/linux64SystemDP/lib/libcore.so (0x00007f405d2db000)
    libsurfMesh.so => /home/kevin/Caelus/Caelus-4.10/platforms/linux64SystemDP/lib/libsurfMesh.so (0x00007f405cff7000)
    liblagrangian.so => /home/kevin/Caelus/Caelus-4.10/platforms/linux64SystemDP/lib/liblagrangian.so (0x00007f405cddb000)
    libconversion.so => /home/kevin/Caelus/Caelus-4.10/platforms/linux64SystemDP/lib/libconversion.so (0x00007f405cb73000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f405fa28000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f405c959000)
    libmpi.so.1 => /home/kevin/Caelus/Caelus-4.10/external/linux/openmpi-1.6.5/lib/libmpi.so.1 (0x00007f405c5b9000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f405c3b0000)
    libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f405c196000)
    libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f405bf93000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f405bd74000)

wyldckat

2015-02-24 10:32

updater   ~0003881

OK, then it's now more clear that this is a "user support" question and not a bug. Although it could be considered a feature request, but it wasn't formulated as such ;)

As for the problem in question, this is roughly explained in the aforementioned section of the installation instructions, namely "User Configuration" at http://www.openfoam.org/download/ubuntu.php

For more details, have a look at the community's wiki page on this topic: http://openfoamwiki.net/index.php/Installation/Working_with_the_Shell - section "2.2 Using aliases to help manage multiple OpenFOAM versions".

user1091

2015-02-24 16:31

  ~0003884

Wyldckat,
Thanks for helping me understand it was the dual openfoam installations which were causing the more recent install to not work. I am okay with the current situation, now that I understand what is going on. You can close the ticket. Thanks again for your help. Once I realized the mis-match between the Caelus install and 2.3.1, I can sort that out on my end.

Issue History

Date Modified Username Field Change
2015-02-23 21:49 user1091 New Issue
2015-02-23 22:23 wyldckat Note Added: 0003873
2015-02-23 22:28 user1091 Note Added: 0003874
2015-02-23 22:32 user1091 Note Added: 0003875
2015-02-23 23:29 wyldckat Note Added: 0003877
2015-02-24 00:11 user1091 Note Added: 0003878
2015-02-24 10:32 wyldckat Note Added: 0003881
2015-02-24 16:31 user1091 Note Added: 0003884
2015-02-24 16:50 henry Status new => resolved
2015-02-24 16:50 henry Resolution open => no change required
2015-02-24 16:50 henry Assigned To => henry