View Issue Details

IDProjectCategoryView StatusLast Update
0001497OpenFOAM[All Projects] Bugpublic2015-02-21 13:04
Reporteruser1067Assigned Touser4 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0001497: extrudeMesh affect quality in non-extruded mesh
DescriptionDoes extrudeMesh affect cell quality in the non-extruded part of the mesh? Starting from an existing mesh whose max nonOrtho quality is 68 deg (checked using checkMesh), doing extrudeMesh with mergeTol = 0, the resulting mesh has max nonOrtho = 70.5 deg from checkMesh log (2 faces found above 70 deg). If we check the position of severely non orthogonal faces we find that they are placed inside the initial mesh, in the non-extruded part.
Steps To ReproduceUntar attached file
blockMesh
checkMesh > log1
extrudeMesh
checkMesh > log2
paraFoam
Additional InformationReported behavior seems to be very dependant on initial mesh (even if mergeTol has been set to 0, so no merge should be done by extrudeMesh).
TagscheckMesh, extrudeMesh

Activities

user1067

2015-01-23 13:18

 

extrudeMeshBug.tar (51,200 bytes)

user4

2015-01-23 15:08

  ~0003579

It works if you write in binary or increase your writePrecision.

Issue History

Date Modified Username Field Change
2015-01-23 13:18 user1067 New Issue
2015-01-23 13:18 user1067 File Added: extrudeMeshBug.tar
2015-01-23 13:31 user1067 Tag Attached: extrudeMesh
2015-01-23 13:31 user1067 Tag Attached: checkMesh
2015-01-23 15:08 user4 Note Added: 0003579
2015-01-23 15:08 user4 Status new => closed
2015-01-23 15:08 user4 Assigned To => user4
2015-01-23 15:08 user4 Resolution open => no change required
2015-02-18 17:40 user4 Status closed => resolved