View Issue Details

IDProjectCategoryView StatusLast Update
0001466OpenFOAM[All Projects] Bugpublic2015-01-01 00:02
ReportersharonyueAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001466: dispersed's phase volume is non-constant when running in parallel
DescriptionI use twoPhaseEulerFoam to simulate liquid-liquid dispersion. its a stirred tank. a closed system, that means all the patch are walls.

I run it perfectly with a single core. "Dispersed phase volume fraction = 0.002" this 0.002 will never change.

But when I run it in parallel. this Dispersed phase volume fraction is going down slowly. U can see the log file.

In this case, I use cyclic boundaries, I also tried with the whole geometry, but it didnot work.I also tried with modify div(phi,alpha) in fvScheme, Also did not work.And the decomposePar method also did not handle this problem.

Well, twoPhaseEulerFoam in openFoam23x can keep this dispersed phase volume constant. But this twoPhaseEulerFoam23x is not the same with twoPhaseEulerFoam22x, cuz in 2.3.x compressible effect is forced in. To be notice that:compressibleTwoPhaseEulerFoam22x also has this problem.
Steps To Reproducejust run twoPhaseEulerFoam directly.

or decomposePar

mpirun ....
TagsNo tags attached.

Activities

sharonyue

2014-12-23 21:49

reporter  

twoPhaseEulerFoam22xmpi.tar.gz (1,768,446 bytes)

sharonyue

2014-12-23 22:01

reporter  

alphaVolumeDown.PNG (15,505 bytes)
alphaVolumeDown.PNG (15,505 bytes)

sharonyue

2014-12-23 22:06

reporter   ~0003360

I add a picture, the reason why the starting point is not 0.002 is because that I did not plot it from the initial time. U can see the dispersed phase volume is going downwards linearly. very very stable. This is also the reason I suspect that maybe this is caused by running in parallel.

Then I tired with a serial running, taking a long time. its quite stable.

sharonyue

2014-12-23 22:56

reporter  

1.PNG (18,224 bytes)
1.PNG (18,224 bytes)

henry

2014-12-23 23:07

manager   ~0003361

twoPhaseEulerFoam is OpenFOAM-2.3.x operates incompressible or compressible and is in fully conservative form.

Issue History

Date Modified Username Field Change
2014-12-23 21:49 sharonyue New Issue
2014-12-23 21:49 sharonyue File Added: twoPhaseEulerFoam22xmpi.tar.gz
2014-12-23 22:01 sharonyue File Added: alphaVolumeDown.PNG
2014-12-23 22:06 sharonyue Note Added: 0003360
2014-12-23 22:56 sharonyue File Added: 1.PNG
2014-12-23 23:07 henry Note Added: 0003361
2014-12-23 23:07 henry Status new => resolved
2014-12-23 23:07 henry Resolution open => fixed
2014-12-23 23:07 henry Assigned To => henry