View Issue Details

IDProjectCategoryView StatusLast Update
0001380OpenFOAM[All Projects] Bugpublic2015-03-02 20:40
Reporterfabian_roeslerAssigned Touser2 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0001380: faceSource does not flip face normals anymore
DescriptionI use a faceZone to sum the face flux phi in order to get the volume flow in simple foam. Recently (about 4 to 6 weeks ago) I did a git pull and compiled the latest bug fixed version of OF 2.3.x. The cases before the git pull calculated the volume flow correctly. After the pull, the volume flow is wrong. I searched for a reason and believe, that the faceSource function does not flip the face normals anymore. I ran parallel cases. The face normals per processor patch were all oriented the same way. So the `bug` only appears in parallel cases with more then one processor per faceZone.
Steps To Reproduce- Take a case and decompose it
- Produce a faceZone to evaluate the volume flow using topoSet
- The faceZone has to be spread over several processors
- Evaluate the volume flow using the faceSource function
TagsNo tags attached.

Activities

fabian_roesler

2014-08-22 09:50

reporter   ~0003214

Possibly related to Bug ID 0001364

user2

2014-08-22 10:25

  ~0003215

There is now a distinction between oriented fields such as phi, and non-oriented fields such as pressure. For your case, can you try defining your function object using:

    orientedFields (phi);

instead of

    fields (phi);

Similarly, the weightField should also be specified using orientedWeightField for phi.

fabian_roesler

2014-08-22 10:38

reporter   ~0003216

This is not working for me. The solver gives the error:

keyword fields is undefined in dictionary "IOstream.functions.massflow"

However, the last git pull was 6 weeks ago. When did you change the function?

user2

2014-08-22 10:49

  ~0003217

The fields entry is still required (for non-oriented fields), so you will need both entries, i.e.:

    fields ();
    orientedFields (phi);

fabian_roesler

2014-08-22 11:34

reporter   ~0003218

Works now! Along the way I did a new git pull and compiled the newest OF 2.3.x.

Where can I find out what has changed from one to the next git pull?

dkxls

2014-08-22 12:47

reporter   ~0003219

Last edited: 2014-08-22 13:17

View 4 revisions

This gives you a list of all changes:
> git log

Once you have the commit of interest, you can see the actual source code changes like this:
> git show 941999150704877d5b2ace6c9d2e937d2c895087

Also the short versions work:
> git show 9419991

To see all changes since a certain commit (quite messy though):
> git diff 941999150704877d5b2ace6c9d2e937d2c895087

Also, if you prefer a GUI: Something like 'qgit' is quite nice. ;)

Issue History

Date Modified Username Field Change
2014-08-22 09:48 fabian_roesler New Issue
2014-08-22 09:50 fabian_roesler Note Added: 0003214
2014-08-22 10:25 user2 Note Added: 0003215
2014-08-22 10:38 fabian_roesler Note Added: 0003216
2014-08-22 10:49 user2 Note Added: 0003217
2014-08-22 11:34 fabian_roesler Note Added: 0003218
2014-08-22 12:47 dkxls Note Added: 0003219
2014-08-22 12:52 dkxls Note Edited: 0003219 View Revisions
2014-08-22 12:54 dkxls Note Edited: 0003219 View Revisions
2014-08-22 13:17 dkxls Note Edited: 0003219 View Revisions
2015-01-01 14:03 henry Status new => closed
2015-01-01 14:03 henry Assigned To => henry
2015-01-01 14:03 henry Resolution open => no change required
2015-03-02 20:40 user4 Assigned To henry => user2
2015-03-02 20:40 user4 Status closed => resolved
2015-03-02 20:40 user4 Resolution no change required => fixed
2015-03-02 20:40 user4 Fixed in Version => 2.3.1