View Issue Details

IDProjectCategoryView StatusLast Update
0001379OpenFOAM[All Projects] Bugpublic2015-03-17 22:46
ReporterprojectionistAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version 
Fixed in Version 
Summary0001379: Weird artificial flow in twoPhaseEulerFoam
DescriptionIn a stagnant simulation case of an air loop reactor an artificial flow forms when the domain has an inclined bottom.
Steps To ReproduceMesh and run the attached to cases and compare results. The setup of the two cases is equal except for the mesh. One case has a flat bottom and the bottom of the other case is chamfered.
TagsNo tags attached.

Activities

projectionist

2014-08-22 09:08

reporter  

StagnantAirLift.tar.gz (75,850 bytes)

projectionist

2014-09-09 09:01

reporter  

StagnantBubbleColumn_curvedBottom.tar.gz (3,418 bytes)

projectionist

2014-09-09 09:09

reporter   ~0003228

I created an even simpler test case, see the file StagnantBubbleColumn_curvedBottom.tar.gz. I took the injection tutorial case from the twoPhaseEulerFoam tutorials, removed the file fvOptions and added this lines to blockMeshDict:

edges
(
    arc 0 1 (0.075 -0.025 0.0)
    arc 4 5 (0.075 -0.025 0.1)
);

Now the 2D bubble column has a curved bottom. If you run the case, you will see strange things are happening.

As the fvOptions are removed, there are no sources. Only gravity is acting and nothing should happen.
However, a strong circulation develops.

user1022

2015-02-05 10:12

  ~0003689

I observed basically the same problem. See http://www.cfd-online.com/Forums/openfoam-solving/148146-bad-momentum-source-vortice-direction-twophaseeulerfoam-non-ortho-meshes.html for a full description!

sharonyue

2015-02-11 04:50

reporter   ~0003747

@projectionist, Im interested into this,and I try to figure it out but failed.

BTW, I downloaded ur curveBottom case, I saw the dispersed phase's initial value is 0.293239, is this value getting down during in your simulation?

henry

2015-03-11 14:32

manager   ~0004084

I have twoPhaseEulerFoam running with a p_rgh formulation consistent with the way this is done in interFoam and compressibleInterFoam which completely removes the spurious currents in the lower part of the vessel but surface currents remain. The issue is that subtracting the hydrostatic part of the pressure only solves the problem of the interaction between the buoyancy force and non-orthogonality in regions of uniform density; at the interface the density gradient is VERY large and the forces do not achieve an equilibrium.

I have a few more test to do before pushing this change but the likelyhood is that if you need cases with a free-surface to converge to 0 flow at least the mesh surrounding the surface will need to be orthogonal.

henry

2015-03-17 22:46

manager   ~0004148

Resolved by commit 50b2edbedc4c36390d6cfccbf295b840990cc4da
in OpenFOAM-dev: https://github.com/OpenFOAM/OpenFOAM-dev

Issue History

Date Modified Username Field Change
2014-08-22 09:08 projectionist New Issue
2014-08-22 09:08 projectionist File Added: StagnantAirLift.tar.gz
2014-09-09 09:01 projectionist File Added: StagnantBubbleColumn_curvedBottom.tar.gz
2014-09-09 09:09 projectionist Note Added: 0003228
2015-02-05 10:12 user1022 Note Added: 0003689
2015-02-11 04:50 sharonyue Note Added: 0003747
2015-03-11 14:32 henry Note Added: 0004084
2015-03-17 22:46 henry Note Added: 0004148
2015-03-17 22:46 henry Status new => resolved
2015-03-17 22:46 henry Resolution open => fixed
2015-03-17 22:46 henry Assigned To => henry
2015-03-24 00:17 liuhuafei Issue cloned: 0001602