View Issue Details

IDProjectCategoryView StatusLast Update
0001363OpenFOAM[All Projects] Bugpublic2015-04-08 16:21
ReporterJuhoAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001363: twoPhaseEulerFoam: Improved treatment of interfacial forces
DescriptionAt least in dispersed vertical pipe flows, the twoPhaseEulerFoam has a strong tendency to produce volume fraction oscillations in regions where lift, dispersion and wall lubrication forces are strong. See the attached "original.png" for an example.

It appears that the issue can be mitigated by including these forces on the cell faces in the pEqn. A version of such implementation is shown in the "Additional Information" field. In the present test case the oscillations were eliminated, as shown in "modified.png"
Additional InformationAn excerpt from the modified pEqn.H:

    surfaceScalarField WF
    (
        fvc::interpolate(fluid.wallLubricationForce()) & mesh.Sf()
    );
    surfaceScalarField LF
    (
        fvc::interpolate(fluid.liftForce()) & mesh.Sf()
    );

    // Phase-1 pressure flux (e.g. due to particle-particle pressure)
    surfaceScalarField phiP1
    (
        "phiP1",
        fvc::interpolate(rAU1*phase1.turbulence().pPrime())
       *fvc::snGrad(alpha1)*mesh.magSf()
    );

    phiP1 +=
        fvc::interpolate(rAU1*fluid.turbulentDispersionForcePrime())
       *fvc::snGrad(alpha1)*mesh.magSf()
      + fvc::interpolate(rAU1)*(WF + LF);

    phiP1.boundaryField() == 0;

    // Phase-2 pressure flux (e.g. due to particle-particle pressure)
    surfaceScalarField phiP2
    (
        "phiP2",
        fvc::interpolate(rAU2*phase2.turbulence().pPrime())
       *fvc::snGrad(alpha2)*mesh.magSf()
    );

    phiP2 +=
        fvc::interpolate(rAU2*fluid.turbulentDispersionForcePrime())
       *fvc::snGrad(alpha2)*mesh.magSf()
      - fvc::interpolate(rAU2)*(WF + LF);

    phiP2.boundaryField() == 0;
TagsNo tags attached.

Activities

Juho

2014-07-30 08:51

reporter  

original.png (46,756 bytes)
original.png (46,756 bytes)

Juho

2014-07-30 08:51

reporter  

modified.png (43,997 bytes)
modified.png (43,997 bytes)

wyldckat

2014-12-29 11:27

updater   ~0003376

@Juho: Can you please provide an example case, in order to make it easier to diagnose and confirm this?

henry

2014-12-29 11:35

manager   ~0003380

I am working on this at the moment and have what I need. I am investigating this in conjunction with http://www.openfoam.org/mantisbt/view.php?id=1313 as the issues relate.

The basic principles are simple but in the case of #1313 a significant rewrite of fvOptions will be required for an elegant implementation. However, the simple interpolation/reconstuction approach proposed will not necessarily conserve the volume integrated force, which for some force models may be important/critical. This is why I have not implemented the approach yet. I am now working on a special interpolation/reconstuction combination which will conserve the integrated force.

wyldckat

2014-12-29 14:45

updater   ~0003394

@Henry: Also seems related to this one: http://www.openfoam.org/mantisbt/view.php?id=1046

sharonyue

2015-02-11 05:04

reporter   ~0003748

@Juho
Could u pls provide some info on "why add these forces on pEqn works better than including them on UEqn?". I mean the basic theory. Thanks.

henry

2015-04-08 16:21

manager   ~0004577

I have converted all forces to be face-based in twoPhaseEulerFoam in OpenFOAM-dev which is beneficial for many case but not all. The behavior is VERY sensitive to the lift modelling and the way in which the curl is handled (an alternative is to use a reconstructed velocity which is smoother). These changes are integrated with the other recent developments including partial-elimination to aid convergence of the drag-coupling and an improved ddtCorr.

Resolved by commit fcbdfd4e44b4a539bcb3514c5607721a4ec1e052

Issue History

Date Modified Username Field Change
2014-07-30 08:51 Juho New Issue
2014-07-30 08:51 Juho File Added: original.png
2014-07-30 08:51 Juho File Added: modified.png
2014-12-29 11:27 wyldckat Note Added: 0003376
2014-12-29 11:35 henry Note Added: 0003380
2014-12-29 14:45 wyldckat Note Added: 0003394
2015-02-11 05:04 sharonyue Note Added: 0003748
2015-03-24 00:17 liuhuafei Issue cloned: 0001608
2015-04-08 16:21 henry Note Added: 0004577
2015-04-08 16:21 henry Status new => resolved
2015-04-08 16:21 henry Resolution open => fixed
2015-04-08 16:21 henry Assigned To => henry