View Issue Details

IDProjectCategoryView StatusLast Update
0001349OpenFOAM[All Projects] Bugpublic2015-02-25 13:22
ReporterbillieAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version13.10
Product Version 
Fixed in Version 
Summary0001349: Probes and sampledSet/cloud do not always find element containing probe location while sampledSet/polyLine does
DescriptionIt seems when the coordinates lie on element boundaries no element is found for the probed location.

The following warning occurs for some locations with the probes function object:
--> FOAM Warning :
    From function findElements::findElements(const fvMesh&)
    in file probes/probes.C at line 111
    Did not find location (0.055 -0.006 0) in any cell. Skipping location.
For the sampled set function object of type cloud no warning is printed.


The attached case contains a controlDict with four different functions.

Function name: probe_Temperature_1
Description: Probes with probe locations on/near element boundaries
Result: some elements are not found

Function name: probe_Temperature_2
Description: Probes with probe locations slightly shifted so they do not lie on element boundaries
Result: all elements are found

Function name: probe_Temperature_3
Description: Set of type cloud with probe locations on/near element boundaries
Result: some elements are not found

Function name: probe_Temperature_4
Description: Set of type polyLine with probe locations on/near element boundaries
Result: all elements are found


Probe locations for which no element is found:
(0.055 -0.006 0)
(0.075 -0.006 0)
(0.08 -0.006 0)
(0.09 -0.006 0)
Steps To ReproduceIt should be possible to reproduce the issue with the attached case. I tried to generate a smaller test-case but I was not able to reproduce the issue with a mesh generated by blockMesh.
TagsfunctionObject, Post-processing, probes, sample

Activities

billie

2014-07-11 20:44

reporter  

test.tar.xz (1,167,924 bytes)

user507

2014-10-14 11:18

  ~0003248

Last edited: 2014-10-14 11:29

View 2 revisions

I can confirm this behaviour. When I specify a probe, it happens that some locations are not found. Moving the probe a small distance, for example 1e-3, resolves the problem. The same happens with sampling lines, sometimes a point is not found, and moving the line slightly resolves everything.

Even tough this bug is possible to work around, it is very annoying and it should be fixed. Especially when doing scripted post-processing, then these "manual" corrections are extremely difficult to handle.

In case the test cases supplied are not sufficient, I can provide more cases where this problem arises.

Update: The problem is also described here: http://www.cfd-online.com/Forums/openfoam-pre-processing/124412-probe-warning-probe-does-not-work.html

user965

2015-01-20 16:04

  ~0003572

I also observe the same behaviour in parallel simulations, with a mesh generated successively using blockMesh and refineHexMesh.

Manually shifting the probes did the trick, but this is very cumbersome.

henry

2015-02-24 17:11

manager   ~0003891

Could you test with the latest commit to OpenFOAM-2.3.x:

commit 3321553039b607239b3d46121c1976546dc1a1b0

    polyMesh::findCell: Add support for octree search and cell tet-decomposition
    Make this new method the default so that probes find the locations more reliably
    Resolves bug-report http://www.openfoam.org/mantisbt/view.php?id=1544

billie

2015-02-25 12:55

reporter   ~0003906

Now all points are found for my case. Thanks for taking care of this issue.

henry

2015-02-25 13:22

manager   ~0003907

Fixed in OpenFOAM-2.3.x

Issue History

Date Modified Username Field Change
2014-07-11 20:44 billie New Issue
2014-07-11 20:44 billie File Added: test.tar.xz
2014-07-11 20:47 billie Tag Attached: functionObject
2014-07-11 20:48 billie Tag Attached: Post-processing
2014-07-11 20:48 billie Tag Attached: sample
2014-07-11 20:48 billie Tag Attached: probes
2014-10-14 11:18 user507 Note Added: 0003248
2014-10-14 11:29 user507 Note Edited: 0003248 View Revisions
2015-01-20 16:04 user965 Note Added: 0003572
2015-02-24 17:11 henry Note Added: 0003891
2015-02-25 12:55 billie Note Added: 0003906
2015-02-25 13:22 henry Note Added: 0003907
2015-02-25 13:22 henry Status new => resolved
2015-02-25 13:22 henry Resolution open => fixed
2015-02-25 13:22 henry Assigned To => henry