View Issue Details

IDProjectCategoryView StatusLast Update
0001205OpenFOAM[All Projects] Bugpublic2016-02-03 21:25
ReporterzordiackAssigned Tohenry 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSXubuntuOS Version13.10
Product Version 
Fixed in Version 
Summary0001205: foamyHexMeshBackgroundMesh is not compilied with root ./Allwmake
DescriptionThe application foamyHexMeshBackgroundMesh is not compiling. This is an important application, because it is needed in order to user the new meshing tool foamyHexMesh in parallel.

The root ./Allwmake is not compliging the application, because it has been commented out in the file OpenFOAM-2.3.x/applications/utilities/mesh/generation/foamyHexMesh/Allwmake. Manual compile with wmake foamyHexMeshBackgroundMesh fails with errors related to CGAL.
Steps To Reproducecd OpenFOAM-2.3.x
./Allwmake
cd applications/utilities/mesh/generation/foamyHexMesh
wmake foamyHexMeshBackgroundMesh
TagsNo tags attached.

Activities

user4

2014-03-05 09:38

  ~0002928

You can run in parallel by just decomposing an initial blockMesh. See the foamyHexMesh mixerVessel tutorial.

albertop

2014-03-06 17:10

reporter   ~0002930

Concerning the problem compiling foamyHexMesh, it does compile if CGAL was successfully built. You should make sure CGAL is properly built first. Make sure you have the required system libraries, and development packages (for example mpfr and mpfr-devel or equivalent for your distribution).
Once you have built CGAL, try to build foamyHexMesh again, and it should work fine.

zordiack

2014-03-07 07:15

reporter   ~0002933

mattijs: I thought this application was supposed to create the constant/backgroundMeshDecomposition, which the blockMesh is using (blockMesh -region backgroundMeshDecomposition). This region is already present in the tutorials, but for a clean case it has to be created.

albertop: I have no trouble compiling foamyHexMesh, this is a different application. And CGAL is compiling just fine.

Build CGAL
    CGAL headers in /home/zordiack/OpenFOAM/ThirdParty-2.3.x/platforms/linux64Clang/CGAL-4.3/include
    CGAL libs in /home/zordiack/OpenFOAM/ThirdParty-2.3.x/platforms/linux64Clang/CGAL-4.3/lib

wyldckat

2015-01-27 22:09

updater   ~0003596

Question: Is it worth while updating the source code for "foamyHexMeshBackgroundMesh" to be compatible with the remaining "foamy*" source code?

Because as far as I can figure out, this utility "foamyHexMeshBackgroundMesh" looks like it was useful during development, but it was not updated when "foamyHexMesh" et al were completed for release.

henry

2015-01-27 22:13

manager   ~0003598

If the presence of foamyHexMeshBackgroundMesh in the source tree is causing confusion I can remove it pending it being brought up to date.

wyldckat

2015-01-27 22:32

updater   ~0003600

Last edited: 2015-01-27 22:33

View 2 revisions

I was thinking more along the lines if a proposed bug fix can come in handy or not!?

henry

2016-02-03 21:25

manager   ~0005905

Resolved in OpenFOAM-dev by commit 94046abbb6e13a973f38e4706d9f9bf17e5b6137

Issue History

Date Modified Username Field Change
2014-03-04 11:01 zordiack New Issue
2014-03-05 09:38 user4 Note Added: 0002928
2014-03-06 17:10 albertop Note Added: 0002930
2014-03-07 07:15 zordiack Note Added: 0002933
2015-01-27 22:09 wyldckat Note Added: 0003596
2015-01-27 22:13 henry Note Added: 0003598
2015-01-27 22:32 wyldckat Note Added: 0003600
2015-01-27 22:33 wyldckat Note Edited: 0003600 View Revisions
2016-02-03 21:25 henry Note Added: 0005905
2016-02-03 21:25 henry Status new => resolved
2016-02-03 21:25 henry Resolution open => fixed
2016-02-03 21:25 henry Assigned To => henry