View Issue Details

IDProjectCategoryView StatusLast Update
0001201OpenFOAM[All Projects] Bugpublic2015-02-05 19:07
Reporteruser871Assigned Tohenry 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSRHELOS Version6.3
Product Version 
Fixed in Version 
Summary0001201: paraviewArchName error in etc/config/paraview.[c]sh scripts
DescriptionRight after installing ParaView-3.12.0 in ThirdParty-2.3.0, I went on to install the PV3Readers:

[user@my_machine PV3Readers]$ ./Allwmake
ERROR: ParaView not found in /home/user/local/OpenFOAM/ThirdParty-2.3.0/platforms/linux64Gcc/paraview-3.12.0

(the directory exists but is actually named ParaView-3.12.0 -- upper case P and V)

... indeed, this is a lower/upper case naming error for the variable paraviewArchName defined in etc/config/paraview.sh (and the corresponding .csh). At first It is defined correctly, but then it gets erroneously modified inside an if statement.
Steps To ReproduceIt occurs always when trying to install the PV3Readers
Additional InformationThe proposed fix is uploaded as a patch
TagsNo tags attached.

Activities

user871

2014-02-28 19:13

 

paraviewArchName.patch (1,120 bytes)
diff --git a/etc/config/paraview.csh b/etc/config/paraview.csh
index 59ddba2..14d6ec3 100644
--- a/etc/config/paraview.csh
+++ b/etc/config/paraview.csh
@@ -87,7 +87,7 @@ set paraviewArchName=ParaView-$ParaView_VERSION
 
 # Reset the name of the binary install directory for version 3
 if ( `echo $ParaView_VERSION | sed -e 's/^\([0-9][0-9]*\).*$/\1/'` == 3) then
-    set paraviewArchName=paraview-$ParaView_VERSION
+    set paraviewArchName=ParaView-$ParaView_VERSION
 endif
 
 setenv ParaView_DIR $WM_THIRD_PARTY_DIR/platforms/$WM_ARCH$WM_COMPILER/$paraviewArchName
diff --git a/etc/config/paraview.sh b/etc/config/paraview.sh
index f883f39..02d742c 100644
--- a/etc/config/paraview.sh
+++ b/etc/config/paraview.sh
@@ -96,7 +96,7 @@ paraviewArchName=ParaView-$ParaView_VERSION
 # Reset the name of the binary install directory for version 3
 if [ `echo $ParaView_VERSION | sed -e 's/^\([0-9][0-9]*\).*$/\1/'` -eq 3 ]
 then
-    paraviewArchName=paraview-$ParaView_VERSION
+    paraviewArchName=ParaView-$ParaView_VERSION
 fi
 
 export ParaView_DIR=$WM_THIRD_PARTY_DIR/platforms/$WM_ARCH$WM_COMPILER/$paraviewArchName
paraviewArchName.patch (1,120 bytes)

wyldckat

2015-02-03 20:26

updater   ~0003664

Confirmed that this proposed patch is... well, almost necessary.


The reason is because the script "etc/tools/ParaViewFunctions" in the "ThirdParty-2.3.*" folder has this innocent looking line:

    ParaView_DIR=$installBASE/ParaView-$ParaView_VERSION

which overrides the address that was carefully rearranged by the aforementioned piece of code in "etc/config/paraview.*" at "OpenFOAM-2.3.*", namely:

    # Reset the name of the binary install directory for version 3
    if [ `echo $ParaView_VERSION | sed -e 's/^\([0-9][0-9]*\).*$/\1/'` -eq 3 ]
    then
        paraviewArchName=paraview-$ParaView_VERSION
    fi



I suggest that the correct solution would be to make the installation consistent among all versions of ParaView, as the "etc/tools/ParaViewFunctions" script tries to imply, i.e., simply therefore remove these 4 lines in "OpenFOAM-2.3.*/etc/config/paraview.*".

henry

2015-02-05 19:07

manager   ~0003699

Resolved by commit a9d1333171c9d35898d2ce00dae656da040d6500

Issue History

Date Modified Username Field Change
2014-02-28 19:13 user871 New Issue
2014-02-28 19:13 user871 File Added: paraviewArchName.patch
2015-02-03 20:26 wyldckat Note Added: 0003664
2015-02-05 19:07 henry Note Added: 0003699
2015-02-05 19:07 henry Status new => resolved
2015-02-05 19:07 henry Resolution open => fixed
2015-02-05 19:07 henry Assigned To => henry