View Issue Details

IDProjectCategoryView StatusLast Update
0001200ThirdParty[All Projects] Bugpublic2015-05-17 11:19
Reporteruser871Assigned Tohenry 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSFedoraOS Version20
Product Version 
Fixed in Version 
Summary0001200: bug in ParaView4Functions checking Qt version
DescriptionQt version in Fedora is 5.2.1

Thus, installing Paraview 4 fails just because makeParaview4 runs into this code:

if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]
then
    echo "*** Error..."

The check for $QtMinor returns true so I get the error having a Qt version greater than 4.5!

This is a possible duplicate of issue #0001088 but I encountered this bug in a different version. But the problem remains the same as sgambati indicated.

By the way, the error message has t o be corrected as well because it says "of a version of Qt >= 4.3" instead of ">=4.5
Steps To ReproduceJust having Qt 5.2.1 installed on the system and trying to install Paraview4.
Additional InformationProposed fix:

if [[ ($QtMajor -lt 4) || ($QtMajor -eq 4 && $QtMinor -lt 5) ]]
then
    echo "***Error: ....
    echo "... version of Qt >=4.5"
TagsNo tags attached.

Activities

user871

2014-02-28 09:52

 

ParaView4Functions.patch (794 bytes)
--- etc/tools/ParaView4Functions	2014-02-06 12:49:42.000000000 +0100
+++ etc/tools/ParaView4Functions.corrected	2014-02-28 10:43:42.665139957 +0100
@@ -332,10 +332,10 @@
         QtMajor=$1
         QtMinor=$2
 
-        if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]
+        if [[ ($QtMajor -lt 4) || ($QtMajor -eq 4 && $QtMinor -lt 5) ]]
         then
             echo "*** Error: Qt version provided < 4.5"
-            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.3 "
+            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.5 "
             echo "***     e.g."
             echo "***         -qmake /usr/local/qt-4.6.2/bin/qmake"
             echo "***         -qmake $installBASE/qt-4.6.2/bin/qmake"

user871

2014-02-28 17:47

 

paraview3+4functions.patch (1,666 bytes)
diff --git a/etc/tools/ParaView4Functions b/etc/tools/ParaView4Functions
index fd9fb24..dc014bd 100644
--- a/etc/tools/ParaView4Functions
+++ b/etc/tools/ParaView4Functions
@@ -332,10 +332,10 @@ addQtSupport()
         QtMajor=$1
         QtMinor=$2
 
-        if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]
+        if [[ ($QtMajor -lt 4) || ($QtMajor -eq 4  && $QtMinor -lt 5) ]]
         then
             echo "*** Error: Qt version provided < 4.5"
-            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.3 "
+            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.5 "
             echo "***     e.g."
             echo "***         -qmake /usr/local/qt-4.6.2/bin/qmake"
             echo "***         -qmake $installBASE/qt-4.6.2/bin/qmake"
diff --git a/etc/tools/ParaViewFunctions b/etc/tools/ParaViewFunctions
index c899556..5c8df79 100644
--- a/etc/tools/ParaViewFunctions
+++ b/etc/tools/ParaViewFunctions
@@ -332,10 +332,10 @@ addQtSupport()
         QtMajor=$1
         QtMinor=$2
 
-        if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]
+        if [[ ($QtMajor -lt 4) || ($QtMajor -eq 4  && $QtMinor -lt 5) ]]
         then
             echo "*** Error: Qt version provided < 4.5"
-            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.3 "
+            echo "***     Please use the -qmake option to specify the location of a version of Qt >= 4.5 "
             echo "***     e.g."
             echo "***         -qmake /usr/local/qt-4.6.2/bin/qmake"
             echo "***         -qmake $installBASE/qt-4.6.2/bin/qmake"

user871

2014-02-28 17:49

  ~0002916

Since the same bug exists in ParaViewFunctions as well I submitted an extra patch concerning both

henry

2015-05-17 11:19

manager   ~0004765

Thanks for the bug-report and patches.
Resolved by commit a83623fdaf5a3ade553f0c60a80da3bfd122c178

Issue History

Date Modified Username Field Change
2014-02-28 09:07 user871 New Issue
2014-02-28 09:52 user871 File Added: ParaView4Functions.patch
2014-02-28 17:47 user871 File Added: paraview3+4functions.patch
2014-02-28 17:49 user871 Note Added: 0002916
2015-05-17 11:19 henry Note Added: 0004765
2015-05-17 11:19 henry Status new => resolved
2015-05-17 11:19 henry Resolution open => fixed
2015-05-17 11:19 henry Assigned To => henry