View Issue Details

IDProjectCategoryView StatusLast Update
0001191OpenFOAM[All Projects] Bugpublic2015-01-18 19:34
ReporterwyldckatAssigned Tohenry 
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Fixed in Version 
Summary0001191: Somewhat dangerous symbolic link based infinite loop in tutorial "mesh/foamyHexMesh/mixerVessel"
DescriptionThere is a somewhat dangerous infinite loop in "tutorials/mesh/foamyHexMesh/mixerVessel/system/", where the sub-folders "backgroundMeshDecomposition" and "cellShapeControlMesh" are pointing to the local "system" folder.

Although this may work just fine for "foamyHexMesh" and any other OpenFOAM applications, this could nonetheless break any other application that needs to check all folder contents and not take into account that such an occurrence can happen, namely that an infinite loop can exist in the file system.
TagsNo tags attached.

Activities

wyldckat

2015-01-18 10:34

updater   ~0003554

It's unclear why "system/cellShapeControlMesh" is necessary. I could not find any evidence in the source code that anything is needed from this folder. If anything, it might be needed from the time folders, but not from the "system" folder.

Therefore, the proposed fix for this report is to run the following commands from within the tutorial folder "mesh/foamyHexMesh/mixerVessel":

    unlink system/backgroundMeshDecomposition
    unlink system/cellShapeControlMesh

    mkdir system/backgroundMeshDecomposition
    ln -s ../decomposeParDict system/backgroundMeshDecomposition/decomposeParDict
    ln -s ../fvSchemes system/backgroundMeshDecomposition/fvSchemes
    ln -s ../fvSolution system/backgroundMeshDecomposition/fvSolution


In addition, I tried to run "Allrun-pre" tutorial a few times to diagnose if this fix is all that is needed, but I was not able to get the same "log.foamyHexMesh" file for two runs for the original tutorial case folder, apparently because the meshing strategy depends enough on random numbers to not be able to reproduce the same output in two consecutive runs.

henry

2015-01-18 19:34

manager   ~0003561

Resolved by commit f7a485069c778495cc39b308580289f6c2d47163

Issue History

Date Modified Username Field Change
2014-02-26 09:44 wyldckat New Issue
2015-01-18 10:34 wyldckat Note Added: 0003554
2015-01-18 19:34 henry Note Added: 0003561
2015-01-18 19:34 henry Status new => resolved
2015-01-18 19:34 henry Resolution open => fixed
2015-01-18 19:34 henry Assigned To => henry