View Issue Details

IDProjectCategoryView StatusLast Update
0001088ThirdParty[All Projects] Bugpublic2015-05-17 11:20
Reporteruser800Assigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0001088: makeParaview
DescriptionThe checkversions function found in ThirdParty-2.2.2/etc/tools/ParaViewFunctions has, what I believe, a mistake on line 333. It currently reads:
if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]. This causes it to report that you have the wrong Qt version if you QtMinor is less than 5 even if your QtMajor is greate than 4. For example I am using Qt 5.1.1 and it reports that my Qt version is less than 4.5. I fixed this by make line 333 this:
if [ $QtMajor -lt 4 -o $QtMajor -eq 4 -a $QtMinor -lt 5 ]

This is an easy change and if you agree with me I know many other people would appreciate this simple change.

Thanks
TagsNo tags attached.

Activities

wyldckat

2013-11-23 13:41

updater   ~0002651

From what I know (although I haven't tested this), ParaView 3.12.0 shouldn't even build with Qt 5.x. Do you mean that you managed to build it with Qt 5.x?

wyldckat

2015-05-17 00:36

updater   ~0004759

Related to http://www.openfoam.org/mantisbt/view.php?id=1200

henry

2015-05-17 11:20

manager   ~0004766

Resolved by commit a83623fdaf5a3ade553f0c60a80da3bfd122c178

Issue History

Date Modified Username Field Change
2013-11-19 19:07 user800 New Issue
2013-11-23 13:41 wyldckat Note Added: 0002651
2015-05-17 00:36 wyldckat Note Added: 0004759
2015-05-17 11:20 henry Note Added: 0004766
2015-05-17 11:20 henry Status new => resolved
2015-05-17 11:20 henry Resolution open => fixed
2015-05-17 11:20 henry Assigned To => henry