View Issue Details

IDProjectCategoryView StatusLast Update
0001082OpenFOAM[All Projects] Bugpublic2015-01-01 14:20
Reporteruser796Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformLinuxOSOtherOS Version(please specify)
Product Version 
Fixed in Version 
Summary0001082: Can not install openfoam in my system completely
DescriptionGetting the error message "gcc: error: unrecognized command line option ‘--showme:link’" while trying to refresh .bashrc after adding the line ". /opt/openfoam222/etc/bashrc" in .bashrc
TagsNo tags attached.

Activities

wyldckat

2013-11-13 14:38

updater   ~0002628

Which Linux Distribution are you using and which installation instructions have you followed?

user796

2013-11-13 15:52

  ~0002630

Platform: Linux
OS: Ubuntu
OS version: 13.10

I tried the following commands to install openfoam222 in my machine:

1. VERS=$(lsb_release -cs)
sudo sh -c "echo deb http://www.openfoam.org/download/ubuntu $VERS main > /etc/apt/sources.list.d/openfoam.list"

2. sudo apt-get update

3. sudo apt-get install openfoam222

Upto this everything is fine.

Then as per the instruction given in the webpage: "http://www.openfoam.org/download/ubuntu.php" I insert the line "source /opt/openfoam222/etc/bashrc" in .bashrc file and refresh the .bashrc file only to get the error message "gcc: error: unrecognized command line option ‘--showme:link’". As a result, installation is not complete and I can not use openfoam.

wyldckat

2013-11-13 16:09

updater   ~0002631

I'm guessing that you have more than one MPI toolbox installed in your machine.

To check this, please run the following command and tell us what's the output it gives you:
   ls -l $(which mpicc) /etc/alternatives/mpicc

user796

2013-11-13 16:26

  ~0002632

The command "ls -l $(which mpicc) /etc/alternatives/mpicc" produce the following output:

lrwxrwxrwx 1 root root 21 Nov 4 02:08 /etc/alternatives/mpicc -> /usr/bin/mpicc.mpich2
lrwxrwxrwx 1 root root 23 Jul 12 18:37 /usr/bin/mpicc -> /etc/alternatives/mpicc

wyldckat

2013-11-13 16:35

updater   ~0002633

There are two ways you can solve this:

1. You can define Open-MPI as the default MPI toolbox, by running:

  sudo update-alternatives --set mpi /usr/lib/openmpi/include


2. Or you can edit the file "/opt/openfoam222/etc/config/settings.sh" and replace "mpicc" with "mpicc.openmpi". This can be done with the following command:

  sudo sed -i -e "s/mpicc/mpicc.openmpi/" /opt/openfoam222/etc/config/settings.sh


@Admins: This isn't the first time I find people that have MPICH2 installed by default in Ubuntu, leading to the problem reported by pinaki.

user796

2013-11-14 03:16

  ~0002635

Thanks a lot. Its working.

Issue History

Date Modified Username Field Change
2013-11-12 10:09 user796 New Issue
2013-11-13 14:38 wyldckat Note Added: 0002628
2013-11-13 15:52 user796 Note Added: 0002630
2013-11-13 16:09 wyldckat Note Added: 0002631
2013-11-13 16:26 user796 Note Added: 0002632
2013-11-13 16:35 wyldckat Note Added: 0002633
2013-11-14 03:16 user796 Note Added: 0002635
2015-01-01 14:20 henry Status new => resolved
2015-01-01 14:20 henry Resolution open => no change required
2015-01-01 14:20 henry Assigned To => henry