View Issue Details

IDProjectCategoryView StatusLast Update
0001039OpenFOAM[All Projects] Bugpublic2015-01-01 14:06
Reporteruser766Assigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntu 13.04OS Version(please specify)
Product Version 
Fixed in Version 
Summary0001039: point probe in libsample.so gives error when probe is close to tank wall.
DescriptionThe following sample dict file in sloshingtank2d, interdymFoam gives the following errors when the point probe is on the wall:

/*--------------------------------*- C++ -*----------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.1.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
FoamFile
{
    version 2.0;
    format ascii;
    class dictionary;
    object probesDict;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //

// Fields to be probed. runTime modifiable!
// To run this file, type "probeLocations" in the solver directory

fields
(
    p
);

// Locations to be probed. runTime modifiable!
probeLocations
(
    (0.0 0.5 -0.3)

);

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //

Then error message is as follows:
Time = 0.55

Time = 0.6

Time = 0.65
--> FOAM Warning :
    From function findElements::findElements(const fvMesh&)
    in file probes/probes.C at line 105
    Did not find location (0 0.5 -0.3) in any cell. Skipping location.
Steps To ReproduceI have definied a tank 1m tall x1m wide and 0.1m deep. The tank is filled with water to depth of 0.5m. The origin is at the midpoint of the air-water interface. Therefore the leftwall of the tank is at -0.5 and the right wall is at +0.5. I have a probe at the left wall at 0.5, -0.3. In other words the probe is just against the wall at a depth of 0.3m from still water surface. When sampleDict is run, the above error appears several times.

based on the referenced error message, it appears that the probe remains static and does not move with the mesh. As a result during certain time steps, the mesh is not at the probe location, hence libsampling.so assumes that the point is outside of the mesh.
Additional InformationThis error goes away if the probe location is at 0.45, -0.3. In other words the probe is placed 0.05m to the left of the right wall
Tagssample

Activities

wyldckat

2014-03-23 18:56

updater   ~0002971

If I'm not mistaken, this has been fixed in OpenFOAM 2.3: http://www.openfoam.org/version2.3.0/post-processing.php - and I quote:

  probes include appropriate treatment for moving mesh cases in which, by default, probes positions are fixed; for moving mesh cases, it can be useful to fix the probed cell instead by setting the optional fixedLocations entry to false.

wyldckat

2014-04-06 00:24

updater   ~0002997

Looks like this was fixed in #1090: http://www.openfoam.org/mantisbt/view.php?id=1090

Issue History

Date Modified Username Field Change
2013-10-08 20:28 user766 New Issue
2014-03-23 18:56 wyldckat Note Added: 0002971
2014-04-06 00:24 wyldckat Note Added: 0002997
2014-12-29 18:36 wyldckat Tag Attached: sample
2015-01-01 14:05 henry Status new => resolved
2015-01-01 14:05 henry Resolution open => fixed
2015-01-01 14:05 henry Assigned To => henry