View Issue Details

IDProjectCategoryView StatusLast Update
0000791OpenFOAM[All Projects] Bugpublic2013-03-19 14:24
ReportermatthiasAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformx64_64OSfedoraOS Version10.047
Product Version 
Fixed in Version 
Summary0000791: functionObject Peclet does not work under special condition
DescriptionDear Support Team,

the function object "Peclet" does not work when no turbulence model is used as e.g. in the icoFoam solver. The problem seems to be at line 160 in Peclet.C There is no transport model "transportProperties" in the object registry, only the tranportProperties dictionary. Maybe one can replace the transportModel class by dictionary class and using simple dict.lookup("nu") to access viscosity here but "nu" still needs to be transformed into the tmp<volScalarField> nuEff.

Best regards

Matthias

  
TagsNo tags attached.

Activities

henry

2013-03-19 14:24

manager   ~0002023

The best option is to setup and run the case with pisoFoam or pimpleFoam and select the "laminar" turbulence model, then all utilities relying on information provided by the turbulence model will work. icoFoam is really only a demonstration solver and not intended for production work.

Issue History

Date Modified Username Field Change
2013-03-19 14:19 matthias New Issue
2013-03-19 14:24 henry Note Added: 0002023
2013-03-19 14:24 henry Status new => resolved
2013-03-19 14:24 henry Resolution open => no change required
2013-03-19 14:24 henry Assigned To => henry