View Issue Details

IDProjectCategoryView StatusLast Update
0000779OpenFOAM[All Projects] Bugpublic2013-03-13 16:35
ReportermatthiasAssigned Tohenry 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMDOSScientifLinux OS Version5.5
Product Version 
Fixed in Version 
Summary0000779: INTEL compiler issue on AMD system
DescriptionDear Support Team,

I installed OF 2.2.x on an AMD cluster using INTEL compiler suite 2013. However the binaries are not working after compilation. The reason is the AMD specific unsupported instruction set SSE4a, which is unsupport by INTEL compilers. So, instead of using the hard coded flag -xSSE3 in "wmake/rules/linux64Icc/c++Opt" I suggest to use -xHost. Thus, the INTEL compiler automatically selects the best optimization level on the system.

Best regards

Matthias
TagsNo tags attached.

Activities

henry

2013-03-13 16:35

manager   ~0001996

Thanks for the suggestion, applied in
commit 6ed5a5036d41faaab3f85447bc363325114106ad

Issue History

Date Modified Username Field Change
2013-03-13 14:41 matthias New Issue
2013-03-13 16:35 henry Note Added: 0001996
2013-03-13 16:35 henry Status new => resolved
2013-03-13 16:35 henry Resolution open => fixed
2013-03-13 16:35 henry Assigned To => henry