2016-12-09 13:34 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000746OpenFOAM[All Projects] Bugpublic2015-02-02 09:51
Reporterchristianfrias 
Assigned Touser4 
PriorityimmediateSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Target VersionFixed in Version 
Summary0000746: refineMesh stops withtout any error and does not write the new mesh
DescriptionI have a mesh created in Pointwise that I want to refine. It was checked with checkMesh, which says that the mesh is OK. However, whenever I try to refine a mesh in all directions (without a dictionary) the program is not able to output any file. The program prompts the following information and then it just stops without any warning or error:

/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.1.1 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 2.1.1-221db2718bbb
Exec : refineMesh
Date : Feb 13 2013
Time : 08:34:06
Host : "christian-HP-Compaq-6000-Pro-MT-PC"
PID : 14901
Case : /media/FriasData2/OpenFOAMRuns/Wabash-Maier/fromz=2ms=2mToRefinedMesh/finerMesh
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create polyMesh for time = 0

Mesh edge statistics:
    x aligned : number:140619 minLen:1.4821 maxLen:2.58947
    y aligned : number:168894 minLen:1.34488 maxLen:2.49935
    z aligned : number:2902843 minLen:1.73402 maxLen:1.95547
    other : number:6346184 minLen:1.34262 maxLen:3.16384

Refining all cells

3D case; refining all directions


I also tried to refine it in parallel using refinMesh -parallel but I get the same result.

Steps To ReproducerefineMesh

or

decomposePar
refineMesh -parallel
Additional InformationThis is the first time I am using binary as an output file format in the control dictionary. Could this be the problem? Should I use ascii instead?
The mesh has approximately 3.3 million of points. Is this a number refineMesh is not able to handle?

The size of the mesh file is around 700MB. I can send it to you maybe using ftp. Let me know.

I tried the same program also in one cluster that we have in our campus and the blacklight cluster from XSEDE with the same result.
TagsNo tags attached.
Attached Files
  • zip file icon bugReport-refineMesh.zip (4,717 bytes) 2013-02-13 14:03
  • txt file icon checkMesh.txt (3,550 bytes) 2013-02-13 21:30 -
    /*---------------------------------------------------------------------------*\
    | =========                 |                                                 |
    | \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
    |  \\    /   O peration     | Version:  2.1.1                                 |
    |   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
    |    \\/     M anipulation  |                                                 |
    \*---------------------------------------------------------------------------*/
    Build  : 2.1.1-1edaa111d2f7
    Exec   : checkMesh -allGeometry -allTopology
    Date   : Feb 13 2013
    Time   : 16:21:14
    Host   : "login0.frank.sam.pitt.edu"
    PID    : 32334
    Case   : /home/jabad/cef26/WabashMaier/meshCalc
    nProcs : 1
    sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
    fileModificationChecking : Monitoring run-time modified files using timeStampMaster
    allowSystemOperations : Disallowing user-supplied system call operations
    
    // * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
    Create time
    
    Create polyMesh for time = 0
    
    Time = 0
    
    Mesh stats
        points:           5347500
        faces:            15258320
        internal faces:   14481544
        cells:            4956644
        boundary patches: 4
        point zones:      0
        face zones:       0
        cell zones:       0
    
    Overall number of cells of each type:
        hexahedra:     4956644
        prisms:        0
        wedges:        0
        pyramids:      0
        tet wedges:    0
        tetrahedra:    0
        polyhedra:     0
    
    Checking topology...
        Boundary definition OK.
        Cell to face addressing OK.
        Point usage OK.
        Upper triangular ordering OK.
        Face vertices OK.
        Topological cell zip-up check OK.
        Face-face connectivity OK.
        Number of regions: 1 (OK).
    
    Checking patch topology for multiply connected surfaces ...
        Patch               Faces    Points   Surface topology                   Bounding box
        inlet               2156     2325     ok (non-closed singly connected)   (419885 4.23762e+06 103) (420154 4.2378e+06 116.058)
        outlet              2156     2325     ok (non-closed singly connected)   (418172 4.2389e+06 103) (418395 4.23911e+06 115.551)
        top                 354046   356500   ok (non-closed singly connected)   (418172 4.23762e+06 115.547) (420689 4.24005e+06 116.058)
        walls               418418   420900   ok (non-closed singly connected)   (418172 4.23762e+06 103) (420689 4.24005e+06 116.058)
    
    Checking geometry...
        Overall domain bounding box (418172 4.23762e+06 103) (420689 4.24005e+06 116.058)
        Mesh (non-empty, non-wedge) directions (1 1 1)
        Mesh (non-empty) directions (1 1 1)
        Boundary openness (6.7399e-17 -2.96842e-17 9.3368e-15) OK.
        Max cell openness = 3.77899e-16 OK.
        Max aspect ratio = 3.51055 OK.
        Minumum face area = 1.32864. Maximum face area = 6.55485.  Face area magnitudes OK.
        Min volume = 2.00468. Max volume = 5.93983.  Total volume = 1.86354e+07.  Cell volumes OK.
        Mesh non-orthogonality Max: 57.9156 average: 14.4889
        Non-orthogonality check OK.
        Face pyramids OK.
        Max skewness = 0.678284 OK.
        Coupled point location match (average 0) OK.
        Face tets OK.
        Min/max edge length = 0.847831 3.65268 OK.
        All angles in faces OK.
        Face flatness (1 = flat, 0 = butterfly) : average = 1  min = 0.996114
        All face flatness OK.
        Cell determinant (wellposedness) : minimum: 0.527384 average: 4.66495
        Cell determinant check OK.
        Concave cell check OK.
    
    Mesh OK.
    
    End
    
    
    txt file icon checkMesh.txt (3,550 bytes) 2013-02-13 21:30 +
  • gz file icon cavity3D.tar.gz (2,006 bytes) 2013-02-16 11:45

-Relationships
+Relationships

-Notes

~0001910

wyldckat (updater)

Did you try doing a full checkMesh? Namely:
   checkMesh -allGeometry -allTopology

And what's the cell count for each type of cell?

~0001912

christianfrias (reporter)

I have uploaded the results from checkMesh -allGeometry -allTopology. As you can see the mesh is actually bigger than I told you at the beginning (around 5.3 million points). It seems that there is no errors according to checkMesh but refineMesh stops before writing the mesh without any warning or error.

Thank you

~0001913

wyldckat (updater)

What units is your mesh in? Because the bounding box is indicating values of "419885 4.23762e+06 103", which if in meters it would be... a lot!

My suggestions are:
 1. Confirm if you original mesh is in millimetre or metre.
 2. Use transformPoints for moving the mesh closer to the origin of the referential. Ideally for the test, I'd suggest that you align the centre of the geometry with the origin of the referential. Then try refineMesh once again.
 3. Last but not least, if possible, build and test with OpenFOAM 2.1.x.

~0001916

christianfrias (reporter)

Hi Thank you for the suggestions.

The coordinates are in meters but they are projected in UTM. That is why it has huge numbers for the bounding box. I translated the mesh as you told me and used OpenFOAM 2.1.x. I finally could refine that mesh without any problems.

~0001922

wyldckat (updater)

Attached is "cavity3D.tar.gz", a simple example case that helps confirm these kinds of situation. It's based on the "incompressible/icoFoam/cavity" tutorial, modified to 3D and added "Allrun" and "Allclean" scripts.

To run, simply use:
  ./Allclean && ./Allrun

In the "Allrun" script are a few transforms, along with comments of the effects of each transform. The errors become more noticeable when the factor between the size of the domain and the offset centre of the cube becomes greater than about 1000.0, which beyond that leads to serious numerical issues.

The curious part comes when trying to visualize these meshes, because it becomes more and more distorted, the more it is moved from the origin!


In conclusion, this is an end-user situation, because ParaView also has issues with very small objects being represented too far away from the origin of the world referential.


The only thing that might on OpenFOAM's side would be to diagnose this, at least with checkMesh, when the mesh has a "mesh size to offset" factor larger than perhaps 1000. Something like this (pseudo-code):

  mag(boundingBox.centre()) / boundingBox.diag().length() > 1000

although this doesn't take into account very flat meshes...

~0003649

user4

Final remark on the OpenFOAM side: if you want to refine all directions it is better to use refineHexMesh.
+Notes

-Issue History
Date Modified Username Field Change
2013-02-13 14:03 christianfrias New Issue
2013-02-13 14:03 christianfrias File Added: bugReport-refineMesh.zip
2013-02-13 20:21 wyldckat Note Added: 0001910
2013-02-13 21:30 christianfrias File Added: checkMesh.txt
2013-02-13 21:31 christianfrias Note Added: 0001912
2013-02-13 21:48 wyldckat Note Added: 0001913
2013-02-14 14:22 christianfrias Note Added: 0001916
2013-02-16 11:45 wyldckat File Added: cavity3D.tar.gz
2013-02-16 11:59 wyldckat Note Added: 0001922
2015-02-02 09:50 user4 Note Added: 0003649
2015-02-02 09:50 user4 Status new => closed
2015-02-02 09:51 user4 Assigned To => user4
2015-02-02 09:51 user4 Resolution open => no change required
+Issue History