View Issue Details

IDProjectCategoryView StatusLast Update
0000621OpenFOAM[All Projects] Bugpublic2013-02-25 13:55
ReportermatthiasAssigned Touser2 
PrioritylowSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
Platformx86_64OSFedoraOS Version16
Product Version 
Fixed in Version 
Summary0000621: PVFoamReader broken due to changes in temporal managment of VTK in ParaView 3.14
DescriptionThe current OpenFOAM reader (paraFoam) is not longer working with ParaView 3.14 or higher due to changes in temporal management of VTK
Additional InformationvtkPV3FoamReader.cxx:321:17: error: »UPDATE_TIME_STEPS« no member of »vtkStreamingDemandDrivenPipeline«

see also
http://www.vtk.org/Wiki/VTK/Remove_vtkTemporalDataSet

VTK_IO_EXPORT has been replaced by VTK_EXPORT
TagsNo tags attached.

Activities

user313

2013-01-25 20:59

  ~0001865

paraview 3.98.0 has the same issue

user2

2013-02-25 13:55

  ~0001943

The reader module is currently designed for ParaView version 3.12

Issue History

Date Modified Username Field Change
2012-08-09 13:29 matthias New Issue
2013-01-25 20:59 user313 Note Added: 0001865
2013-02-25 13:55 user2 Note Added: 0001943
2013-02-25 13:55 user2 Status new => resolved
2013-02-25 13:55 user2 Resolution open => no change required
2013-02-25 13:55 user2 Assigned To => user2