2016-12-09 13:34 GMT

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000534OpenFOAM[All Projects] Bugpublic2012-06-13 11:08
Reportertoorop33 
Assigned Touser4 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version11.1
Product Version 
Target VersionFixed in Version 
Summary0000534: kOmegaSSTSAS requests RASModel RASProperties
DescriptionChanged motorbike pisoFoam RAS-LES tutorial:
RAS - kOmegaSST
LES - kOmegaSSTSAS

At the very first iteration of the LES simulation after the k equation is solved the solver quits with the following error:
--> FOAM FATAL ERROR:
request for RASModel RASProperties from objectRegistry region0 failed available objects of type RASModel are

0
(
)

From function objectRegistry::lookupObject<Type>(const word&) const
in file /home/tibornyers/OpenFOAM/OpenFOAM-2.1.x/src/OpenFOAM/lnInclude/objectRegistryTemplates.C at line 131.
Steps To Reproducerun ./Allrun script
Additional Information
At cfd-online.com the first thread that discusses the issue was started in 2010. Since I couldn't find any kOmegaSSTSAS tutorials the community may misunderstand something about the use of this LES model.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0001387

user4

Your case is set up to use wall functions. The kOmegaSSTSAS is a low-Re model.

~0001388

user2

This case was set up for RAS turbulence, and applied RAS-based wall functions. If you want to convert the case to use LES, you will need to update the boundary conditions accordingly.

For the kOmegaSSTSAS model, we have not implemented a k-wall function boundary condition for LES - if you can supply a reference we could add the functionality in a future release (or quicker under a support contract).

In the meantime, it is probably more appropriate to set a nut wall function, and apply fixed-value (0) on k.

~0001394

toorop33 (reporter)

Thank you for the information, sorry for my misunderstanding!
+Notes

-Issue History
Date Modified Username Field Change
2012-05-10 13:40 toorop33 New Issue
2012-05-10 13:43 toorop33 File Added: motorBike.tar.gz
2012-06-12 14:35 user4 Note Added: 0001387
2012-06-12 14:35 user4 Status new => closed
2012-06-12 14:35 user4 Assigned To => user4
2012-06-12 14:35 user4 Resolution open => no change required
2012-06-12 14:35 user4 Fixed in Version => 2.1.1
2012-06-12 14:53 user2 Note Added: 0001388
2012-06-13 11:04 toorop33 Note Added: 0001394
2012-06-13 11:04 toorop33 Status closed => feedback
2012-06-13 11:04 toorop33 Resolution no change required => reopened
2012-06-13 11:08 henry Status feedback => closed
2012-06-13 11:08 henry Resolution reopened => fixed
+Issue History