View Issue Details

IDProjectCategoryView StatusLast Update
0000459OpenFOAM[All Projects] Bugpublic2012-09-04 11:36
ReporternogenmyrAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version10.04
Product Version 
Fixed in Version 
Summary0000459: Topochanges causes seg fault in ODEChemistryModel
DescriptionIf a mesh undergoes a topological change and the ODEChemistryModel class is used by the solver, typically for a PaSR-model simulation, internal fields in the ODEChemistryModel class needs to be updated/mapped to the new mesh. Care for this is taken for the RR_ object at line 708 in ODEChemistryModel.C. However, also the deltaTChem object needs to be updated. A simple hack like this solves it: (ugly solution)

l704ff:
    if (this->mesh().changing())
    {
        for (label i = 0; i < nSpecie_; i++)
        {
            RR_[i].setSize(this->mesh().nCells());
            RR_[i] = 0.0;
        }
        this->deltaTChem_.setSize(this->mesh().nCells());
        this->deltaTChem_ = 1e-6;
    }

Nicer would probably be to interpolate from old mesh, or set it to the initialChemicalTimeStep given by the user in chemistryProperties.

Best regards,
Kalle
Steps To ReproduceFor instance, run a case with finite rate chemistry combustion and adaptive mesh refinement. (User modded reactingFoam solver)
TagsNo tags attached.

Relationships

duplicate of 0000637 resolvedhenry basicChemistryModel incompatible with dynamicRefineFvMesh 

Activities

nogenmyr

2012-09-04 07:40

reporter   ~0001669

This issue was reported again and resolved here:

http://www.openfoam.org/mantisbt/view.php?id=637

Status can now be set to "resolved"

K

Issue History

Date Modified Username Field Change
2012-03-13 20:03 nogenmyr New Issue
2012-09-04 07:40 nogenmyr Note Added: 0001669
2012-09-04 11:36 henry Relationship added duplicate of 0000637
2012-09-04 11:36 henry Status new => resolved
2012-09-04 11:36 henry Resolution open => duplicate
2012-09-04 11:36 henry Assigned To => henry