View Issue Details

IDProjectCategoryView StatusLast Update
0000370OpenFOAM[All Projects] Bugpublic2012-01-31 11:56
Reporteruser313Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformlinuxOSredhatOS Version(please specify)
Product Version 
Fixed in Version 
Summary0000370: openmpi-1.5.3 doesn't work
DescriptionSimilar report as Bug-ID:0000296

After clean up and rebuild with openmpi-1.4.4
openmpi-1.4.4 works.


log:
------------------------------
crc.nd.edu{zwei1}58: mpirun -np 4 icoFoam -parallel
/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.1.0 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 2.1.0
Exec : icoFoam -parallel
Date : Dec 22 2011
Time : 12:46:47
Host : "opteron.crc.nd.edu"
PID : 26576
Case : /afs/crc.nd.edu/user/z/zwei1/OpenFOAM/OpenFOAM-2.1.0/tutorials/incompressible/icoFoam/test
nProcs : 4
Slaves :
3
(
"opteron.crc.nd.edu.26577"
"opteron.crc.nd.edu.26578"
"opteron.crc.nd.edu.26579"
)

Pstream initialized with:
    floatTransfer : 0
    nProcsSimpleSum : 0
    commsType : nonBlocking
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 0

[0] [2]
[0]
[0] --> FOAM FATAL IO ERROR:
[0] error in IOstream "IOstream" for operation operator>>(Istream&, List<T>&) : reading first token
[0]

[2] [3] [0] file: IOstream at line 0.
[0]
[0] From function IOstream::fatalCheck(const char*) const
[0] in file db/IOstreams/IOstreams/IOstream.C at line 114.
[0]
FOAM parallel run exiting
[0]
[1]
[1]
[3]
[3] --> FOAM FATAL IO ERROR:
[3] error in IOstream "IOstream" for operation operator>>(Istream&, List<T>&) : reading first token
[3]
[3] file: IOstream at line 0.
[3]
[2] --> FOAM FATAL IO ERROR:
[2] error in IOstream "IOstream" for operation operator>>(Istream&, List<T>&) : reading first token
[2]
[2] file: IOstream at line 0.
[2]
[2] From function IOstream::fatalCheck(const char*) const
[2] in file db/IOstreams/IOstreams/IOstream.C at line 114.
[2]
FOAM parallel run exiting
[2]

[1] --> FOAM FATAL IO ERROR:
[1] error in IOstream "IOstream" for operation operator>>(Istream&, List<T>&) : reading first token
[1]
[1] file: IOstream at line 0.

[3] From function IOstream::fatalCheck(const char*) const
[3] in file db/IOstreams/IOstreams/IOstream.C at line 114.
[3]
FOAM parallel run exiting
[3]
[1]
[1] From function IOstream::fatalCheck(const char*) const
[1] in file db/IOstreams/IOstreams/IOstream.C at line 114.
[1]
FOAM parallel run exiting
[1]
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 3 in communicator MPI_COMM_WORLD
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun has exited due to process rank 2 with PID 26578 on
node opteron.crc.nd.edu exiting without calling "finalize". This may
have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).
--------------------------------------------------------------------------
[opteron.crc.nd.edu:26573] 3 more processes have sent help message help-mpi-api.txt / mpi-abort
[opteron.crc.nd.edu:26573] Set MCA parameter "orte_base_help_aggregate" to 0 to see all help / error messages
TagsNo tags attached.

Activities

user4

2011-12-23 10:30

  ~0000867

Sounds like something is left behind. After switching it should be enough just to clean out the Pstream library (cd src/Pstream; rmoall; ./Allwmake)

Can you repeat the problem with a tutorial?

user2

2012-01-31 11:56

  ~0000982

orphaned report - closing

Issue History

Date Modified Username Field Change
2011-12-22 21:48 user313 New Issue
2011-12-23 10:30 user4 Note Added: 0000867
2012-01-31 11:56 user2 Note Added: 0000982
2012-01-31 11:56 user2 Status new => closed
2012-01-31 11:56 user2 Resolution open => fixed