View Issue Details

IDProjectCategoryView StatusLast Update
0003656OpenFOAMBugpublic2021-04-13 14:07
ReporterjkauAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version20.04
Product Versiondev 
Fixed in Version 
Summary0003656: prghEntrainmentPressure write entry "rho" twice, therefore ParaView can not load the "p_rgh" field
Descriptionsee summary
Steps To Reproducee.g. run DTCHullMoving tutorial and load the results in ParaView
TagsNo tags attached.

Activities

henry

2021-04-08 15:03

manager   ~0011964

Try using paraFoam.

jkau

2021-04-08 15:17

reporter   ~0011965

paraFoam is not an alternative (e.g. due to headless installation and required functionalities from ParaView version 5.9). However attached patch should fix the issue.

prghEntrainment.patch (639 bytes)
diff --git a/src/finiteVolume/fields/fvPatchFields/derived/PrghPressure/PrghPressureFvPatchScalarField.C b/src/finiteVolume/fields/fvPatchFields/derived/PrghPressure/PrghPressureFvPatchScalarField.C
index ea4289102..23576ce41 100644
--- a/src/finiteVolume/fields/fvPatchFields/derived/PrghPressure/PrghPressureFvPatchScalarField.C
+++ b/src/finiteVolume/fields/fvPatchFields/derived/PrghPressure/PrghPressureFvPatchScalarField.C
@@ -125,7 +125,6 @@ void Foam::PrghPressureFvPatchScalarField<PressureFvPatchScalarField>::
 write(Ostream& os) const
 {
     PressureFvPatchScalarField::write(os);
-    writeEntry(os, "rho", rhoName_);
 }
 
 
prghEntrainment.patch (639 bytes)

henry

2021-04-08 15:26

manager   ~0011967

Last edited: 2021-04-08 15:27

View 2 revisions

The bug is in the paraview reader, you will need to report the issue to the maintainers of that reader if you do not want to use the reader we provide and maintain.

The patch you have provided will break other patch fields using PrghPressureFvPatchScalarField, what testing have you done on it?

henry

2021-04-08 15:28

manager   ~0011968

You can use the reader we provide with ParaView version 5.9 but we don't recommend using this version of ParaView due to some serious bugs in it.

jkau

2021-04-08 15:42

reporter   ~0011969

I have tested on the DTCHullMoving tutorial.

henry

2021-04-08 15:51

manager   ~0011970

That is not sufficient testing, you will need to test ALL the patch fields based on PrghPressureFvPatchScalarField.

henry

2021-04-09 10:36

manager   ~0011971

I tested the paraFoam reader with ParaView version 5.9 on the DTCHullMoving case and there were no problems.

Issue History

Date Modified Username Field Change
2021-04-08 14:53 jkau New Issue
2021-04-08 15:03 henry Note Added: 0011964
2021-04-08 15:17 jkau File Added: prghEntrainment.patch
2021-04-08 15:17 jkau Note Added: 0011965
2021-04-08 15:26 henry Note Added: 0011967
2021-04-08 15:27 henry Note Edited: 0011967 View Revisions
2021-04-08 15:28 henry Note Added: 0011968
2021-04-08 15:42 jkau Note Added: 0011969
2021-04-08 15:51 henry Note Added: 0011970
2021-04-09 10:36 henry Note Added: 0011971
2021-04-09 10:36 henry Assigned To => henry
2021-04-09 10:36 henry Status new => closed
2021-04-09 10:36 henry Resolution open => no change required