View Issue Details

IDProjectCategoryView StatusLast Update
0003655OpenFOAMBugpublic2021-04-08 13:10
ReporterjkauAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version20.04
Product Versiondev 
Fixed in Version 
Summary0003655: outletPhaseMeanVelocity fails in case of scale instead of constant value for UMean
Descriptiontested with recent dev (commit f8d557e3429f46bb8fd7781400fa8b0d26d20938 from April 1st)

When using function1 scale for UnMean instead of a constant value, execution exits with Fatal Error
Steps To ReproduceIn tutorial multiphase/interFoam/laminar/wave/, change
UnMean 2;
to
        UnMean
        {
                type scale;
                scale
                {
                        type quarterSineRamp;
                        start 0;
                        duration 100;
                }
                value 2;
        }

interFoam (or decompose) will fail after setWaves.
TagsNo tags attached.

Activities

henry

2021-04-08 12:29

manager   ~0011961

What Fatal Error? Is the problem that you have set an initial velocity of 0, i.e. it starts with no mean flow?

jkau

2021-04-08 13:02

reporter   ~0011962

--> FOAM FATAL IO ERROR:
wrong token type - expected word, found on line 56 the label 2

But I think the problem was due to incorrect specification of the scaling. With:
                value
                {
                        type quarterSineRamp;
                        start 0;
                        duration 100;
                }
                scale 2;

it works. Of course the scaling values itself do not make sense for this case, i.e. starting wiht velocity of 0. It was just to reproduce the Error.

henry

2021-04-08 13:10

manager   ~0011963

User support request.

Issue History

Date Modified Username Field Change
2021-04-08 12:00 jkau New Issue
2021-04-08 12:29 henry Note Added: 0011961
2021-04-08 13:02 jkau Note Added: 0011962
2021-04-08 13:10 henry Assigned To => henry
2021-04-08 13:10 henry Status new => closed
2021-04-08 13:10 henry Resolution open => no change required
2021-04-08 13:10 henry Note Added: 0011963