View Issue Details

IDProjectCategoryView StatusLast Update
0003646OpenFOAMBugpublic2021-03-22 08:06
ReporterdavvalokAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Product Versiondev 
Fixed in Version 
Summary0003646: C1 coefficient in CoulaloglouTavlaridesCoalescence model
DescriptionC1 in the CoulaloglouTavlaridesCoalescence.C is rather large. Looking at the equation referenced in the paper (37), the value is multiplied by 1e-6.
Is it possible that somewhere in the code, this value is multiplied by 1e-6 or scaled-down?

Path to code:
https://github.com/OpenFOAM/OpenFOAM-dev/blob/7e3f4976a83d4834b876be7cacd573faa20f1faa/applications/solvers/multiphase/multiphaseEulerFoam/phaseSystems/populationBalanceModel/coalescenceModels/CoulaloglouTavlaridesCoalescence/CoulaloglouTavlaridesCoalescence.C



Additional InformationThe equation is rather similar to the following paper Eqs (8 and 9):
Hsia, M. Alexander, and Lawrence L. Tavlarides. "A simulation model for homogeneous dispersions in stirred tanks." The Chemical Engineering Journal 20.3 (1980): 225-236.
Note that in Hsia the rates are calculated with diameters rather than volumes.
TagsNo tags attached.

Activities

davvalok

2021-03-22 07:58

reporter   ~0011949

The issue is resolved. The unit of the volume is cm3.

Issue History

Date Modified Username Field Change
2021-03-21 16:49 davvalok New Issue
2021-03-22 07:58 davvalok Note Added: 0011949
2021-03-22 08:06 henry Assigned To => henry
2021-03-22 08:06 henry Status new => closed
2021-03-22 08:06 henry Resolution open => no change required