View Issue Details

IDProjectCategoryView StatusLast Update
0003629OpenFOAMFeaturepublic2021-02-15 14:52
Reportermichal_wietlickiAssigned Tohenry 
PriorityhighSeverityblockReproducibilityhave not tried
Status closedResolutionno change required 
PlatformUnix Ubuntu 18.04OSOS Version
Product Version8 
Fixed in Version 
Summary0003629: Can not compile a user made solver using wmake
DescriptionI'm trying to edit pimpleFoam application in a specific way that has already been done by a user. Trouble is that steps for compilation where not mentioned by the user and I can not compile myself, I get the following error:

mkdir: cannot create directory ‘/opt/openfoam8/platforms/linux64GccDPInt32Opt/applications’: Permission denied
/bin/sh: 1: cannot create /opt/openfoam8/platforms/linux64GccDPInt32Opt/applications/solvers/incompressible/EHDpimpleFoam/SRFPimpleFoam/options: Directory nonexistent
make: *** No rule to make target '/opt/openfoam8/platforms/linux64GccDPInt32Opt/applications/solvers/incompressible/EHDpimpleFoam/SRFPimpleFoam/options'. Stop.
/bin/sh: 1: cannot create /opt/openfoam8/platforms/linux64GccDPInt32Opt/applications/solvers/incompressible/EHDpimpleFoam/SRFPimpleFoam/options: Directory nonexistent
make: *** No rule to make target '/opt/openfoam8/platforms/linux64GccDPInt32Opt/applications/solvers/incompressible/EHDpimpleFoam/SRFPimpleFoam/options', needed by 'all'. Stop.
wmake error: file '/opt/openfoam8/platforms/linux64GccDPInt32Opt/applications/solvers/incompressible/EHDpimpleFoam/SRFPimpleFoam/sourceFiles' could not be created in /opt/openfoam8/applications/solvers/incompressible/EHDpimpleFoam/SRFPimpleFoam

I've seen the thread (https://bugs.openfoam.org/view.php?id=927) by wyldcat on how to resolve this issue, but this does not seem to fix it for me. Not sure if I'm making a mistake somewhere or if in my case it is not sufficient.


Steps To ReproduceThe EHDpimpleFoam/Make/files is:

EHDpimpleFoam.C

        LIB = $(FOAM_USER_LIBBIN)/EHDpimpleFoam

The EHDpimpleFoam/Make/files is of the format:

EXE_INC = \
 
list of libaries - copied from pimplefoam

LIB_LIBS = \

list of libraries - copied from pimpleFoam

if I change the first EXE_INC to LIB_EXE I get the same error.

I've edited the MAKE in the SRFPimpleFoam subdirectory of EHDpimpleFoam to be the same.
TagsNo tags attached.

Activities

henry

2021-02-15 14:52

manager   ~0011880

User support request.

Issue History

Date Modified Username Field Change
2021-02-15 14:24 michal_wietlicki New Issue
2021-02-15 14:52 henry Assigned To => henry
2021-02-15 14:52 henry Status new => closed
2021-02-15 14:52 henry Resolution open => no change required
2021-02-15 14:52 henry Note Added: 0011880