View Issue Details

IDProjectCategoryView StatusLast Update
0002230OpenFOAM[All Projects] Bugpublic2016-09-03 03:23
ReporternitskiyAssigned Towyldckat 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSDebianOS Version7.1
Product Versiondev 
Fixed in Version 
Summary0002230: Build crash
DescriptionEarly error while building from git source:

+ OSspecific/POSIX/Allwmake -fromWmake
In file included from /share/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/Time.H:44:0,
                 from signals/sigStopAtWriteNow.C:30:
/share/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/FIFOStack.H: In instantiation of ‘class Foam::FIFOStack<Foam::word>’:
/share/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/Time.H:136:33: required from here
/share/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/FIFOStack.H:62:26: error: no members matching ‘Foam::SLList<Foam::word> {aka Foam::LList<Foam::SLListBase, Foam::word>}::SLList’ in ‘Foam::SLList<Foam::word> {aka class Foam::LList<Foam::SLListBase, Foam::word>}’
make: *** [/share/OpenFOAM/OpenFOAM-dev/platforms/linux64Gcc47DPInt32Opt/src/OSspecific/POSIX/signals/sigStopAtWriteNow.o] Error 1
Steps To Reproduce1)git clone git://github.com/OpenFOAM/OpenFOAM-dev.git
2) edit and source bashrc
3) ./Allwmake
Additional Informationversion 4.0 builded OK on same host. Both gcc version 4.7 and icc version > 15.0
TagsNo tags attached.

Activities

wyldckat

2016-09-02 14:45

updater   ~0006801

A few questions:

 1. What were the exact changes you've made to the "OpenFOAM-dev/etc/bashrc" file?
 2. What was the exact command used for sourcing the "OpenFOAM-dev/etc/bashrc" file?
 3. Did you use a clean shell environment when you sourced the "bashrc" file?

wyldckat

2016-09-03 03:22

updater   ~0006803

I've tested building OpenFOAM-dev with GCC 4.7.2 (Debian 7 and Ubuntu 12.10), 4.7.3 (Ubuntu 13.04) and 4.7.4 (Ubuntu 16.04 g++-4.7 package) and all of them gave the same exact error message. I was hoping this was a parser glitch that had already been fixed in more recent patch versions, but it's not.

This is consistent with what's detailed in the README.org file in ThirdParty-dev, namely that GCC 4.8 is now the minimum required version needed for building OpenFOAM-dev: https://github.com/OpenFOAM/ThirdParty-dev#openfoam-dev-third-party-packages

This requirement was necessary due to OpenFOAM's code has been upgraded to use C++11 support exclusively, which it's only partial in 4.7. For more details, see the commit list starting from here: https://github.com/OpenFOAM/OpenFOAM-dev/commits/7656c076c8b79b22cb649480872c000b34961bbb

Therefore, you'll need to install GCC 4.8 (both "gcc" and "g++") in your system, in order to build OpenFOAM-dev.

I'll close this report as "no change required".

Issue History

Date Modified Username Field Change
2016-09-02 14:06 nitskiy New Issue
2016-09-02 14:45 wyldckat Note Added: 0006801
2016-09-03 03:22 wyldckat Note Added: 0006803
2016-09-03 03:23 wyldckat Status new => closed
2016-09-03 03:23 wyldckat Assigned To => wyldckat
2016-09-03 03:23 wyldckat Resolution open => no change required