View Issue Details

IDProjectCategoryView StatusLast Update
0001681OpenFOAM[All Projects] Bugpublic2015-10-18 19:32
Reporteruser1130Assigned Towyldckat 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Version 
Fixed in Version 
Summary0001681: Actuator disks add instead of reducing momentum. This is solved by changing the disk 180 degrees,but then 'diskDir' is not right
DescriptionThe library works just fine for specific directions but for others not. To be more specific, for some directions, the "diskDir" vector found in "system/fvOptions", needs an opposite sign from the "windDirection" vector found in "0/include/ABLconditions"

From 280 to 140 degrees, I get the cases working with the vector configurations, being the same between the two files, as given by the files below:

-file: "0/include/ABLconditions"
\*---------------------------------------------------------------------------*/

Uref 15.0;
Href 500.0;
windDirection (0.866025403784 0.5 0);
zDirection (0 0 1);

// ************************************************************************* //

-file: "system/fvOptions"

disk1
{
        type actuationDiskSource;
        active on;
        selectionMode cellSet;
        cellSet actuationDisk1;
        actuationDiskSourceCoeffs
        {
           fieldNames (U);
           diskDir (0.866025403784 0.5 0);
           Cp 0.53;
           Ct 0.4;
           diskArea 3019.0705401;
           upstreamPoint (-612.255455478 573.888162569 326.6);
        }
}

For other directions (like this one), the "diskDir" vector needs opposite signs when compared to the "windDirection" vector found in "0/include/ABLconditions". I do not know why this is happening

-file: "0/include/ABLconditions"
\*---------------------------------------------------------------------------*/

Uref 15.0;
Href 500.0;
windDirection (0.866025403784 0.5 0);
zDirection (0 0 1);

// ************************************************************************* //

-file: "system/fvOptions"

disk1
{
        type actuationDiskSource;
        active on;
        selectionMode cellSet;
        cellSet actuationDisk1;
        actuationDiskSourceCoeffs
        {
           fieldNames (U);
           diskDir (-0.866025403784 -0.5 0);
           Cp 0.53;
           Ct 0.4;
           diskArea 3019.0705401;
           upstreamPoint (-612.255455478 573.888162569 326.6);
        }
}
Additional InformationI have attached two figures. The one has common values for "diskDir" and "windDirection" inputs, but giving wrong results, and the other one has opposite signs for "diskDir" and "windDirection" inputs, but produces the right results.

I do not know why this is happening. I guess "diskDir" does not utilize correctly the vector notation.

Thank you in advance. Feel free to ask me for any other information.

Best regards,

Nick
TagsNo tags attached.

Relationships

related to 0001847 closedwyldckat actuationDiskSourceTemplates.C - Calculation of Usource and sign convention 

Activities

user1130

2015-04-30 14:55

 

Actuator disk report.pdf (300,228 bytes)

user1130

2015-05-05 18:29

  ~0004717

I checked all upstream points for each disk. I also tried to modify the "p1" and "p2" values defined in "topoSetDict" file, by simply considering the p2 as p1 and the p1 as p2. Did not make any difference so far. I am not expert to judge but my impression is that "diskDir" is the issue, since changing the signs only of the vector, works like a charm, although "diskDir" is wrong. Still trying to figure out....

user1130

2015-05-21 11:53

  ~0004781

Hi People,

Would you like me to upload a small case to test?

Kind regards,

Nick

wyldckat

2015-05-21 20:54

updater   ~0004783

Greetings Nick,

Yes, please provide a couple of small test cases, if possible, because those would make it a lot easier/faster to diagnose the problem! Otherwise, it take longer for the person diagnosing the problem, since the case examples would still have to be prepared. And it's not a certainty that the exact same error is triggered.
The other possibility is whether you're able to reproduce the same error with one of OpenFOAM's tutorials.

Specially because I've got a suspicion that it's the upstream point that is leading to some mathematical ambiguity...

Best regards,
Bruno

user1130

2015-06-05 12:13

  ~0004889

Last edited: 2015-06-05 12:15

View 2 revisions

Hi Bruno,

I have prepared some cases for your review testing all sectors from 0 to 360 with a 30 degree sectoral difference(12 sectors in total). From the cases uploaded the problem arises in the following directions: 210, 240, 270
(I have not included the one at 180 but checked that too)

From the cases working, I have selected two of them to attach. These are at 90 degrees and 330 degrees, where one can check that the "diskDir" vector found in "fvOptions" file, when compared with the "windDirection" found in "ABLConditions" file has the same range of values.

For the ones that do not work as supposed, the vectors of "diskDir and "windDirection" files are different.

Regarding the upstream point, I have trying checking for all sectors modifications with higher and lower distance to the rotor, but nothing seems to change with the addition/reduction of momentum problem. Here is a picture http://postimg.org/image/ds459lgxh/ ,where the red point is the point representing the tower position and the black point is where the upstream point is selected. Similarly in this figure too but with different orientation, http://postimg.org/image/a55krz5r7/

Here are the links for all cases. Inside the folder of the first file (part1), there is a text file named "Details" with the summary of the cases working and not working.

http://we.tl/rlDnWEAoFl
http://we.tl/RuVdDyZxa4
http://we.tl/hnj8arQcqE


Do not hesitate to ask me for any more info.

Best regards,

Nick

wyldckat

2015-09-05 17:54

updater  

turbineSitingRotated30.tar.gz (387,101 bytes)

wyldckat

2015-09-05 17:54

updater  

turbineSitingRotated155.tar.gz (387,111 bytes)

wyldckat

2015-09-05 18:00

updater   ~0005335

Hi Nick,

Unfortunately only today did I manage to take a look into this. Since 3 months have passed since you posted the files at "we.tl", they are now long gone and I didn't download them any sooner :(

Nonetheless I've tried to test this with OpenFOAM 2.4.x and I was not able to reproduce the same error that you got.
I've attached two test cases:

 * turbineSitingRotated30.tar.gz
 * turbineSitingRotated155.tar.gz

Both are the tutorial "incompressible/simpleFoam/turbineSiting", where the first is rotated 30 degrees and the second is rotated 155 degrees. Both cases were completely rotated: mesh, "ABLConditions" and "fvOptions".

If possible, please re-upload the test cases you had uploaded before.

Best regards,
Bruno

wyldckat

2015-10-18 19:29

updater  

turbineSitingRotated210.tar.gz (387,107 bytes)

wyldckat

2015-10-18 19:30

updater   ~0005430

I've attached the test case "turbineSitingRotated210.tar.gz", which tries to reproduce another one of the reported angles that were susceptible to the wrong calculation. I was not able to reproduce the same error.

@Nick: If and when you find the time, please re-upload the cases and re-open this bug report. But in the meantime I'll close it as "unable to reproduce".

Issue History

Date Modified Username Field Change
2015-04-30 14:55 user1130 New Issue
2015-04-30 14:55 user1130 File Added: Actuator disk report.pdf
2015-05-05 18:29 user1130 Note Added: 0004717
2015-05-21 11:53 user1130 Note Added: 0004781
2015-05-21 20:54 wyldckat Note Added: 0004783
2015-06-05 12:13 user1130 Note Added: 0004889
2015-06-05 12:15 user1130 Note Edited: 0004889 View Revisions
2015-09-05 12:19 wyldckat Relationship added related to 0001847
2015-09-05 17:54 wyldckat File Added: turbineSitingRotated30.tar.gz
2015-09-05 17:54 wyldckat File Added: turbineSitingRotated155.tar.gz
2015-09-05 18:00 wyldckat Note Added: 0005335
2015-10-18 19:29 wyldckat File Added: turbineSitingRotated210.tar.gz
2015-10-18 19:30 wyldckat Note Added: 0005430
2015-10-18 19:32 wyldckat Status new => closed
2015-10-18 19:32 wyldckat Assigned To => wyldckat
2015-10-18 19:32 wyldckat Resolution open => unable to reproduce