View Issue Details

IDProjectCategoryView StatusLast Update
0001046OpenFOAM[All Projects] Bugpublic2014-12-29 14:54
ReporteralbertopAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionsuspended 
PlatformLinuxOSopenSUSEOS Version12.3
Product Version 
Fixed in Version 
Summary0001046: Sign of lift force is inverted in twoPhaseEulerFoam/compressibleTwoPhaseEulerFoam
DescriptionThe sign of the lift force seems to be inverted in twoPhaseEulerFoam and compressibleTwoPhaseEulerFoam.

If the momentum equation of the dispersed phase "1" has the lift term on the RHS, then the lift force acting on the dispersed phase should be:

Flift,1 = - Cl*alpha1*rho2*(U2 - U1) x curl(U)

However, in twoPhaseEulerFoam/compressibleTwoPhaseEulerFoam,

Ur = U1 - U2,

and

liftCoeff = Cl*(alpha2*rho2 + alpha1*rho1)*(Ur ^ fvc::curl(U))

This term appears with a negative sign in U1Eqn and a positive one in U2Eqn, while it should be the opposite.
TagsNo tags attached.

Activities

henry

2013-10-14 12:37

manager   ~0002543

This is a matter of convension which is not consistent in all publications on the matter. The current form of the lift model was first implemented in bubbleFoam for David Hill:

@PhdThesis{ Hill:PhD,
  author = "Hill, D.P.",
  title = "The Computer Simulation of Dispersed Two-Phase Flow",
  school = "Imperial College of Science, Technology and Medicine",
  year = 1998
}

See page 68 and previous pages.

If the current general consesus is for the sign to be changed I do not have an issue with the change. Could you provide suitable references for the definition you are advocating?

albertop

2013-10-15 18:43

reporter   ~0002549

Thank you for the reference. Indeed, the sign of the lift force as implemented in twoPhaseEulerFoam is consistent with the original reference of Drew and Lahey:

D.A. Drew, R.T. Lahey Jr, The virtual mass and lift force on a sphere in rotating and straining inviscid flow, International Journal of Multiphase Flow. 13 (1987) 113–121

I would say you can safely ignore my comment on the sign. There seem to be some confusion in the literature, because some other authors change the sign to lift the force. A summary of the models is here:

S.M. Monahan, V.S. Vitankar, R.O. Fox, CFD predictions for flow-regime transitions in bubble columns, AIChE Journal. 51 (2005) 1897–1923.

There seems to be consensus on the form of the lift force however, which is written in terms of the liquid properties, rather than of the mixture properties:

Fl = alpha1*Cl*rho2*(U2 - U1) x curl(U2)

I assume the mixture formulation was chosen to deal with cases with phase inversion.

henry

2013-10-15 22:01

manager   ~0002550

> I assume the mixture formulation was chosen to deal with cases with phase
> inversion.

It certainly has advantaged for this otherwise some kind of blending and/or switching would be needed. The current lift modelling is not very satisfactory and depending on the cleanliness of the system the coefficient may be of either sign. Do you think the form above is preferable to the original form based on the mixture velocity?

albertop

2013-10-16 22:41

reporter   ~0002554

The form based on the liquid seems to be the most used in the literature, but both the forms seem to provide similar results.

What is puzzling is that even for small values of the coefficient (0.01 or smaller), bubbles are pushed on the wall causing the formation of a layer of gas with very high phase fraction.

henry

2013-10-16 22:54

manager   ~0002555

We have found the same behaviour and generally do not use the lift model.

Juho

2013-10-17 08:53

reporter   ~0002556

I believe on high-Re meshes the lift force is excessively large in the near wall cells because the lift calculation is not based on the wall functions. The gradient towards the wall is not captured correctly. In simulations of vertical bubbly channel flows, the lift force has to be included to obtain proper radial void distributions. Lacking a better approach, what we do is disable the lift force in the near wall cells. The results are much better.

Overall, I think the state-of-art in Eulerian near wall modelling of bubbly flows is quite unsatisfactory. A lot of strongly coupled models like wall lubrication forces used to balance the lift force, which makes the results highly sensitive.

henry

2013-10-17 09:19

manager   ~0002557

I am not convinced that adjusting the near-wall gradient using wall-functions is sufficient to compensate for the over-estimation of the lift effect in the near-wall region but it is easy to implement if it is of general interest.

Filtering the lift-force in the near-wall cells may be a more robust approach pending the development of more reliable modelling.

henry

2014-12-29 14:54

manager   ~0003397

It appears that the current lift-force modelling is badly bahaved in the near-wall region and at the very least some kind of damping needs to be applied, probably based on the ratio of the particle size to the distance to the wall. Once suitable models have been developed and validated it will be straight forward to include them in OpenFOAM.

Issue History

Date Modified Username Field Change
2013-10-14 06:36 albertop New Issue
2013-10-14 12:37 henry Note Added: 0002543
2013-10-15 18:43 albertop Note Added: 0002549
2013-10-15 22:01 henry Note Added: 0002550
2013-10-16 22:41 albertop Note Added: 0002554
2013-10-16 22:54 henry Note Added: 0002555
2013-10-17 08:53 Juho Note Added: 0002556
2013-10-17 09:19 henry Note Added: 0002557
2014-12-29 14:54 henry Note Added: 0003397
2014-12-29 14:54 henry Status new => closed
2014-12-29 14:54 henry Assigned To => henry
2014-12-29 14:54 henry Resolution open => suspended