View Issue Details

IDProjectCategoryView StatusLast Update
0003287OpenFOAMFeaturepublic2019-06-04 10:38
ReporterlorenzotrevisanAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
Platformx86_64OSSlackwareOS Version14.2
Product Versiondev 
Fixed in Version 
Summary0003287: solidificationMelting fvOption seems not implemented for liquid phase in any multiphase solver that includes it.
DescriptionsolidificationMelting fvOption seems not implemented for liquid phase in any multiphase solver that includes it.
I expect that for immiscible fluids if a liquid is present, a solidificatioMeltingSource would be possible to apply to it, as like a fvOption.liquid directory, similar to what already heppens for thermophysicalProperties.
Additional InformationIn my opinion this feature would be crucial in order to consider a Stefan problem as per ice formation (water->ice in air) due to density variation.
TagsNo tags attached.

Activities

henry

2019-06-03 14:19

manager   ~0010506

> solidificationMelting fvOption seems not implemented for liquid phase in any multiphase solver

That is correct, the sponsor of this development did not need multiphase capability.

It would of course be possible to extend it for multiphase application if an organisation were interested enough to fund the development.

henry

2019-06-04 10:38

manager   ~0010509

Pending funding.

Issue History

Date Modified Username Field Change
2019-06-03 13:55 lorenzotrevisan New Issue
2019-06-03 14:19 henry Note Added: 0010506
2019-06-04 10:38 henry Assigned To => henry
2019-06-04 10:38 henry Status new => closed
2019-06-04 10:38 henry Resolution open => suspended
2019-06-04 10:38 henry Note Added: 0010509