View Issue Details

IDProjectCategoryView StatusLast Update
0003235OpenFOAMBugpublic2019-05-10 20:11
ReporterviragAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformUnixOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Version 
Summary0003235: Compilation error in OpenFOAM-Dev
DescriptionThe current version of OpenFOAM-Dev from github is not compiling:
in CentOS Linux release 7.6.1810. Tried with couple of version of gcc as suggested in 0003130

g++ -std=c++11 -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=64 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -Wno-attributes -O3 -DNoRepository -ftemplate-depth-100 -I/home/virag/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/src/OpenFOAM -IlnInclude -I. -I/home/virag/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude -I/home/virag/OpenFOAM/OpenFOAM-dev/src/OSspecific/POSIX/lnInclude -fPIC -c primitives/strings/lists/hashedWordList.C -o /home/virag/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/src/OpenFOAM/primitives/strings/lists/hashedWordList.o
g++ -std=c++11 -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=64 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -Wno-attributes -O3 -DNoRepository -ftemplate-depth-100 -I/home/virag/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/src/OpenFOAM -IlnInclude -I. -I/home/virag/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude -I/home/virag/OpenFOAM/OpenFOAM-dev/src/OSspecific/POSIX/lnInclude -fPIC -c primitives/strings/stringOps/stringOps.C -o /home/virag/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/src/OpenFOAM/primitives/strings/stringOps/stringOps.o
make: *** [/home/virag/OpenFOAM/OpenFOAM-dev/wmake/rules/General/transform:26: /home/virag/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt64Opt/src/OpenFOAM/primitives/functions/Function1/makeFunction1s.o] Error 1
make: *** Waiting for unfinished jobs....
TagsNo tags attached.

Activities

will

2019-05-10 08:55

manager   ~0010458

The message you posted does not include the error. Please upload the entire build log.

virag

2019-05-10 19:34

reporter  

log.make (625,888 bytes)

henry

2019-05-10 20:11

manager   ~0010461

I have tested building OpenFOAM-dev with several gcc versions and it compiled without error with all of them.

Issue History

Date Modified Username Field Change
2019-05-09 22:59 virag New Issue
2019-05-10 08:55 will Note Added: 0010458
2019-05-10 19:34 virag File Added: log.make
2019-05-10 20:11 henry Assigned To => henry
2019-05-10 20:11 henry Status new => closed
2019-05-10 20:11 henry Resolution open => unable to reproduce
2019-05-10 20:11 henry Note Added: 0010461