2017-10-21 23:57 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002644OpenFOAM[All Projects] Bugpublic2017-08-14 09:14
Reporterarmin.shv 
Assigned Towill 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version14.04
Product Versiondev 
Target VersionFixed in Version 
Summary0002644: Particle tracking cannot be run in parallel for the cases with AMI patches.
DescriptionParticle tracking cannot be run in parallel for the cases with AMI patches.
It says: "Particle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor."
But the decomposition of AMI patches on one processor through the "singleProcessorFaceSets" function in decomposeParDict leads to the same error!


Constructing kinematicCloud kinematicCloud
[2] [3]
[3]
[3] --> FOAM FATAL ERROR:
[3] Particle tracking across AMI patches is only currently supported for cases where the AMI patches reside on a single processor
[3]
[3] From function void Foam::Cloud<ParticleType>::checkPatches() const [with ParticleType = Foam::CollidingParcel<Foam::KinematicParcel<Foam::particle> >]
[3] in file /home/armin/OpenFOAM/OpenFOAM-dev/src/lagrangian/basic/lnInclude/Cloud.C at line 59.
[3]
FOAM parallel run aborting
TagsAMI, Lagrangian, parallel
Attached Files

-Relationships
+Relationships

-Notes

~0008490

will (manager)

Could you please upload the case that reproduces the error?

~0008491

armin.shv (reporter)

Hi Will,
yes, it's already there.

~0008496

will (manager)

It's not the same error on decomposePar. Your "singleProcessorFaceSets" setting is referencing a face-set that doesn't exist.

There is a bug that generates a hang in this case, to do with initialisation of the TrackData::switchProcessor flag. I will fix it, but it is not the issue described here, so it would be misleading to associate that fix with resolution if this report.

~0008497

armin.shv (reporter)

Thanks Will.
Yes, the "singleProcessorFaceSets" setting in the decomposeParDict of this case refers to another case with the faceSet "AMI", where it leads to the same error. I can send that case too in order to show, that this setting doesn't solve the problem. But it's not the main problem. I've already sent a simple case just to show the main problem: Particle tracking cannot be run in parallel for the cases with AMI patches.

~0008498

will (manager)

It does work if you create an AMI face set and the appropriate singleProcessorFaceSets entry in the decomposeParDict. It's running on my machine right now.

You have not demonstrated that there is a bug anywhere. The fact that the AMI patches must reside on the same process is a limitation, sure, but the error message explains this.

~0008504

armin.shv (reporter)

Okay, since I cannot upload more here, I will send another report with a case with "singleProcessorFaceSets" setting, which leads to the same error.

And about this limitation, that particle tracking cannot be run in parallel for the cases with AMI patches, I've read in the bug report 0002081, that "a workaround has been provided which can overcome the issue and a more user-friendly solution requires funding at this stage.". Therefore I'm eagerly waiting for the new workaround. It would be very interesting for me.

~0008505

armin.shv (reporter)

After writing of the last note the upload part is enabled again. Therefore I've uploaded the second case (rotatingDisc) here as well.
As you can see, the AMI faceSet resides now only on the processor 5. But the particle tracking (log.icoUncoupledKinematicParcelDyMFoam) gives the same error.

~0008506

will (manager)

There's no bug. This is a user support request.

~0008563

armin.shv (reporter)

Thank you for your hints, Will. I found the solution.

Regards,
Armin
+Notes

-Issue History
Date Modified Username Field Change
2017-08-01 16:11 armin.shv New Issue
2017-08-01 16:11 armin.shv Tag Attached: AMI
2017-08-01 16:11 armin.shv Tag Attached: Lagrangian
2017-08-01 16:11 armin.shv Tag Attached: parallel
2017-08-01 16:22 will Note Added: 0008490
2017-08-01 17:56 armin.shv File Added: mixerVesselAMI2D.tar.gz
2017-08-01 17:59 armin.shv Note Added: 0008491
2017-08-02 10:06 will Assigned To => will
2017-08-02 10:06 will Status new => closed
2017-08-02 10:06 will Resolution open => no change required
2017-08-02 10:06 will Note Added: 0008496
2017-08-02 11:58 armin.shv Status closed => feedback
2017-08-02 11:58 armin.shv Resolution no change required => reopened
2017-08-02 11:58 armin.shv Note Added: 0008497
2017-08-02 14:46 will Status feedback => closed
2017-08-02 14:46 will Resolution reopened => no change required
2017-08-02 14:46 will Note Added: 0008498
2017-08-03 13:38 armin.shv Status closed => feedback
2017-08-03 13:38 armin.shv Resolution no change required => reopened
2017-08-03 13:38 armin.shv Note Added: 0008504
2017-08-03 13:48 armin.shv File Added: rotatingDisc.tar.gz
2017-08-03 13:57 armin.shv Note Added: 0008505
2017-08-03 13:57 armin.shv Status feedback => assigned
2017-08-03 18:34 will Status assigned => closed
2017-08-03 18:34 will Resolution reopened => no change required
2017-08-03 18:34 will Note Added: 0008506
2017-08-12 14:14 armin.shv Status closed => feedback
2017-08-12 14:14 armin.shv Resolution no change required => reopened
2017-08-12 14:14 armin.shv Note Added: 0008563
2017-08-14 09:14 will Status feedback => closed
2017-08-14 09:14 will Resolution reopened => no change required
+Issue History